Status

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: ken.vandine, Assigned: ken.vandine)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(firefox59 fixed, firefox60 fixed)

Details

Attachments

(2 attachments)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20180226180053

Steps to reproduce:

Recent changes to the snapcraft.yaml requires some new files be copied into ${WORKSPACE}.  This causes a build failure missing mimeapps.list and mime-handler.xml
Comment on attachment 8956066 [details]
Bug 1443144 - Fix snap build failure caused by files not being copied into ${WORKSPACE}

https://reviewboard.mozilla.org/r/225004/#review230964

Sorry for missing that, in my previous reviews.
Attachment #8956066 - Flags: review?(jlorenzo) → review+
Assignee: nobody → ken.vandine
Blocks: snappy
Depends on: 1441920
Comment on attachment 8956066 [details]
Bug 1443144 - Fix snap build failure caused by files not being copied into ${WORKSPACE}

Approval Request Comment
[Feature/Bug causing the regression]: None
[User impact if declined]: Unable to ship the first Snap release. Snaps are a new package format powered by Canonical.
[Is this code covered by automated tests?]: N/A
[Has the fix been verified in Nightly?]: N/A. Releng crafts Snap on beta. Starting Firefox 59, Snap are also built on release.
[Needs manual test from QE? If yes, steps to reproduce]: No. This has been tested by Canonical's QA.
[List of other uplifts needed for the feature/fix]: N/A
[Is the change risky?]: No
[Why is the change risky/not risky?]: This is a Snap only fix for 59. It has no impact on the regular product.
[String changes made/needed]: None.
Attachment #8956066 - Flags: approval-mozilla-release?
Comment on attachment 8956066 [details]
Bug 1443144 - Fix snap build failure caused by files not being copied into ${WORKSPACE}

Fix needed for Snap builds, which we want to ship for Fx59. Approved for 59rc1.
Attachment #8956066 - Flags: approval-mozilla-release? → approval-mozilla-release+
Pushed by jlorenzo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/058cc826edb6
Fix snap build failure caused by files not being copied into ${WORKSPACE} r=jlorenzo
Thank you very much for the super quick approval, Ryan! 

I landed the patch on mozilla-release before it reached central: https://hg.mozilla.org/releases/mozilla-release/rev/5d05e188fe7ceb8d89d4aebdbc006ae79d0375d9. The reasons are:
* This code isn't run on mozilla-central, but only on beta and release
* Only linters run on push. I manually ran shellcheck to ensure nothing was broken.
* The code actually runs on mozilla-beta and release when builds are promoted.
Comment on attachment 8956092 [details]
Bug 1443144 - part2: Fix bad shell quotes  a=RyanVM

https://reviewboard.mozilla.org/r/225030/#review230980

ooh, nasty shell expansion, good catch
Attachment #8956092 - Flags: review?(sfraser) → review+
(In reply to Simon Fraser [:sfraser] ⌚️GMT from comment #8)
> ooh, nasty shell expansion, good catch

Kudos to Ken who found it before GTB. I landed the fixup on m-r at https://hg.mozilla.org/releases/mozilla-release/rev/7f9be73fde97dd6831b2954bd37afe477ecb0573
Pushed by jlorenzo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f00eccec1c83
part2: Fix bad shell quotes r=sfraser a=RyanVM
https://hg.mozilla.org/mozilla-central/rev/058cc826edb6
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.