Closed Bug 1443249 Opened 4 years ago Closed 3 years ago

Search doesn't find occurrence when scrolled away in a div

Categories

(Core :: Find Backend, defect)

60 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1436431

People

(Reporter: mail, Unassigned)

References

()

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180305100134

Steps to reproduce:

When I browse to https://github.com/ceph/ceph-ansible/issues/632 and search (Ctrl+F) for "notinstalled".

I'm using Firefox Nightly 60 on Ubuntu 16.04.


Actual results:

, it claims that there's no occurrence on the page, even though there is, namely in the the first code box on that page. But the string "NOTINSTALLED" in that code box is not visible in the viewport because to see it I have to scroll that code box to the right.

When I scroll the text box to the right, and search again, Firefox finds the string.


Expected results:

Firefox should find the string in all cases.

I cannot reproduce this bug from a clean profile with the same Firefox version.

When I start `~/opt/firefox-nightly/firefox/firefox -profile tmpprofile/ --no-remote --new-instance` and go to the page, the problem disappears.

In my normal profile, the problem persists even when I restart Firefox in safe mode (all extensions disabled).

It doesn't seem to be caused by my settings either: When I copy `prefs.js` from my profile into `tmpprofile` and run `~/opt/firefox-nightly/firefox/firefox -profile tmpprofile/ --no-remote --new-instance`, then the bug is still not present.

How can I debug this?

Is there other state in Firefox beyond prefs and plugins that may cause this difference?
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
20180305100134

Also see bug 1436431, bug 1441486.

(In reply to Niklas Hambüchen from comment #0)
> I cannot reproduce this bug from a clean profile with the same Firefox
> version.

It also works for me. I can only reproduce this if I switch findbar.modalHighlight to true, and even then only if I type very quickly.
Has Regression Range: --- → irrelevant
Has STR: --- → yes
Component: Untriaged → Find Toolbar
Product: Firefox → Toolkit
Even with a new profile and on 60 i can still find this bug!
however @Gingerbread Man has a point that if typing manually it does find the "notinstalled", but if one uses copy/past (similar to writing too quickly or using barcode scanners) it is unable to find the string
Still, and !funny enough, as i mentioned in bug 1436431, in my case even typing slowly it does not find the string. But scrolling a bit in any direction (but still having the string "hidden") will allow firefox to find it
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
20180308100121

(In reply to Maverick from comment #2)
> if one uses copy/past (similar to writing too
> quickly or using barcode scanners) it is unable to find the string

Works for me. Even with findbar.modalHighlight = true, Ctrl+F then Ctrl+V is fine.

Please include your user agent string and build ID from about:support when posting such comments.
(In reply to Gingerbread Man from comment #4)
> Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101
> Firefox/60.0
> 20180308100121
> 
> (In reply to Maverick from comment #2)
> > if one uses copy/past (similar to writing too
> > quickly or using barcode scanners) it is unable to find the string
> 
> Works for me. Even with findbar.modalHighlight = true, Ctrl+F then Ctrl+V is
> fine.
> 
> Please include your user agent string and build ID from about:support when
> posting such comments.

Hi, Sorry, here it is:
Mozilla/5.0 (X11; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Duping to bug 1436431 as per bug 1448087, comment 3.

Please test the latest Nightly in a brand new profile and reopen if the issue is still reproducible.
https://nightly.mozilla.org
https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Component: Find Toolbar → Find Backend
Product: Toolkit → Core
Resolution: --- → DUPLICATE
Duplicate of bug: 1436431
You need to log in before you can comment on or make changes to this bug.