Crash in nsSimpleCharString

VERIFIED WORKSFORME

Status

()

Core
XPCOM
P3
critical
VERIFIED WORKSFORME
19 years ago
19 years ago

People

(Reporter: rickg, Assigned: dougt)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Simply navigating through pages on NT causes this crash repeatedly:

nsDebug::Assertion(const char * 0x10080dac, const char * 0x10080d94, const char
* 0x10080d70, int 200) line 181 + 13 bytes
nsSimpleCharString::ReleaseData() line 200 + 35 bytes
nsSimpleCharString::~nsSimpleCharString() line 83
nsFileSpec::~nsFileSpec() line 929 + 11 bytes
nsFileTransport::~nsFileTransport() line 131 + 89 bytes
nsFileTransport::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsFileTransport::Release(nsFileTransport * const 0x02ef6cf0) line 158 + 99 bytes
nsPipe::~nsPipe() line 182 + 27 bytes
nsPipe::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsPipe::Release(nsPipe * const 0x02ef5090) line 186 + 98 bytes
nsPipe::nsPipeInputStream::Release(nsPipe::nsPipeInputStream * const 0x02ef5098)
line 304
nsExpatTokenizer::HandleExternalEntityRef(void * 0x02ef5a10, const char *
0x00000000, const char * 0x02acc4a8, const char * 0x02acc558, const char *
0x00000000) line 622 + 12 bytes
doProlog(void * 0x02ef5a10, const encoding * 0x010756f8 little2_encoding, const
char * 0x02ac85c4, const char * 0x02acac18, int 17, const char * 0x02ac85c6,
const char * * 0x0012d41c) line 2272 + 36 bytes
prologProcessor(void * 0x02ef5a10, const char * 0x02ac8478, const char *
0x02acac18, const char * * 0x0012d41c) line 2145 + 36 bytes
prologInitProcessor(void * 0x02ef5a10, const char * 0x02ac8478, const char *
0x02acac18, const char * * 0x0012d41c) line 2134 + 21 bytes
XML_Parse(void * 0x02ef5a10, const char * 0x02ac8478, int 10144, int 0) line 867
+ 40 bytes
nsExpatTokenizer::ParseXMLBuffer(const char * 0x02ac8478, unsigned int 10144,
int 0) line 286 + 24 bytes
nsExpatTokenizer::ConsumeToken(nsScanner & {...}) line 329 + 18 bytes
nsParser::Tokenize(int 0) line 1439 + 21 bytes
nsParser::ResumeParse(nsIDTD * 0x00000000, int 0) line 909 + 12 bytes
nsParser::OnDataAvailable(nsParser * const 0x02ef4254, nsIChannel * 0x02ef4c90,
nsISupports * 0x00000000, nsIInputStream * 0x02ef49f8, unsigned int 0, unsigned
int 5072) line 1327 + 19 bytes
nsDocumentBindInfo::OnDataAvailable(nsDocumentBindInfo * const 0x02ef32d0,
nsIChannel * 0x02ef4c90, nsISupports * 0x00000000, nsIInputStream * 0x02ef49f8,
unsigned int 0, unsigned int 5072) line 1347 + 32 bytes
nsChannelListener::OnDataAvailable(nsChannelListener * const 0x02ef3160,
nsIChannel * 0x02ef4c90, nsISupports * 0x00000000, nsIInputStream * 0x02ef49f8,
unsigned int 0, unsigned int 5072) line 1588
nsFileChannel::OnDataAvailable(nsFileChannel * const 0x02ef4c94, nsIChannel *
0x02ef4b90, nsISupports * 0x00000000, nsIInputStream * 0x02ef49f8, unsigned int
0, unsigned int 5072) line 486
nsOnDataAvailableEvent::HandleEvent(nsOnDataAvailableEvent * const 0x02ef49b0)
line 345
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x02ef49b4) line 144 + 12 bytes
PL_HandleEvent(PLEvent * 0x02ef49b4) line 541 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x029209a0) line 500 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x004607fe, unsigned int 49322, unsigned int 0,
long 43125152) line 970 + 9 bytes
USER32! 77e71250()
029209a0()

Updated

19 years ago
Assignee: dp → dougt
(Assignee)

Comment 1

19 years ago
ccing warren.  could this be cause by changes to your pipe code?
(Assignee)

Comment 2

19 years ago
rickg, do you know what the assert said?  I can not reproduce this, but I have
a older tree.  I am updating now.

Comment 3

19 years ago
Doesn't look like anything to do with pipes. Looks like a filespec bug to me,
glancing at the stack.
(Assignee)

Comment 4

19 years ago
yeah, I was reaching.  not much has changed in nsFileSpec to assert where it is
asserting.  It is a double release assert on the internal buffer (according
to the stack trace).  I ask rickg if that is what he saw the assert say.  Once
my tree is build, I will try to reproduce and fix it.
(Reporter)

Comment 5

19 years ago
Sorry -- it was late and I was awake enough to write down the assert message.
I'll be back in San Diego tomorrow, and if I see it again, I'll update this bug.
(Assignee)

Comment 6

19 years ago
although I do not doubt that this happened to you, I can not reproduce it on my
machine.  continuing to surf...
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 7

19 years ago
rickg, are you still seeing this?  I have not been able to reproduce this.
Could this be caused by modifications of your tree?  Marking as WORKFORME.
Reopen if you can reproduce this.

Updated

19 years ago
QA Contact: beppe → paulmac

Comment 8

19 years ago
reassigning to paulmac, please redistribute to the appropriate QA

Comment 9

19 years ago
This bug no longer occurs for some time.  Marking Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.