[Regression][CSD] Wrong titlebar button icons on some themes

RESOLVED FIXED in Firefox 60

Status

()

defect
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: bruno.n.pagani, Assigned: stransky)

Tracking

(Blocks 1 bug)

Trunk
mozilla61
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox60 fixed, firefox61 fixed)

Details

Attachments

(2 attachments)

Reporter

Description

a year ago
Posted image CSD_button_icon.png
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20100101

Steps to reproduce:

Following https://bugzilla.mozilla.org/show_bug.cgi?id=1408335, this issue has been fixed in the past but recently regressed.

I’m using Arc Theme.
Assignee

Updated

a year ago
Assignee: nobody → stransky
Assignee

Comment 1

a year ago
Seems to be regression from Bug 1434646.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee

Comment 2

a year ago
It's because we style the button icons before we put the titlebar button to the actual titlebar - so we render the icons for standalone buttons instead of the titlebar ones.

Comment 4

a year ago
mozreview-review
Comment on attachment 8956478 [details]
Bug 1443481 - [Linux/Titlebar] Construct widget tree to get correct titlebar icon style before we render the actual icon,

https://reviewboard.mozilla.org/r/225390/#review231566
Attachment #8956478 - Flags: review?(jhorak) → review+
Comment hidden (mozreview-request)

Comment 6

a year ago
Pushed by stransky@redhat.com:
https://hg.mozilla.org/integration/autoland/rev/8c038bd77897
[Linux/Titlebar] Construct widget tree to get correct titlebar icon style before we render the actual icon, r=jhorak

Comment 7

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/8c038bd77897
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61

Updated

a year ago
Duplicate of this bug: 1438636
Comment on attachment 8956478 [details]
Bug 1443481 - [Linux/Titlebar] Construct widget tree to get correct titlebar icon style before we render the actual icon,

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1434646
[User impact if declined]: Wrong titlebar icons on Ambiance (Ubuntu) Gtk+ theme.
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: Change is isolated to internal button creation.
[String changes made/needed]: none
Attachment #8956478 - Flags: approval-mozilla-beta?
Comment on attachment 8956478 [details]
Bug 1443481 - [Linux/Titlebar] Construct widget tree to get correct titlebar icon style before we render the actual icon,

fix a regression in beta60 with some themes on gtk
Attachment #8956478 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.