acrobat reader plugin crashes

VERIFIED WONTFIX

Status

Plugins Graveyard
PDF (Adobe)
--
critical
VERIFIED WONTFIX
16 years ago
2 years ago

People

(Reporter: marc schuette, Assigned: rubydoo123)

Tracking

({crash})

Details

(Whiteboard: [ACROBAT BUG], URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc2)
Gecko/20020510
BuildID:    2002051006

when opening url http://www.mscdirect.com/PDF.process?pdf=1503&Section_Id=1498 i
get a program error for acrobat.exe - no entries are generated in the
application error log. i can still close the browser window or even reload it
(which gives me the same error again). i have mozilla 1.0 rc2 and acrobat reader
5.05 with search.

Reproducible: Always
Steps to Reproduce:
1.open http://www.mscdirect.com/PDF.process?pdf=1503&Section_Id=1498
2.
3.

Actual Results:  a breif flash of the adobe acrobat reader splash screen and then...
a windows dialog box titled 'program error'- acrobat.exe has generated errors
and will be closed by windows. you will need to restart the program. an error
log is being created.

Expected Results:  opened the pdf inline with the browser window

Comment 1

16 years ago
WFM 2002051208/trunk/W2K with Adobe Acrobat Plug-In Version 5.00
Severity: major → critical
Keywords: crash

Comment 2

16 years ago
i could not crash either with 0512 br on NT. reporter, is this a random case or 
do u see it continuously?
(Reporter)

Comment 3

16 years ago
i just tried it here at work where i use full version of adobe acrobat 
4.0 - and it opened ok. at home where i reported the bug i have adobe 
reader ver 5.05 with search and it was repeatable. do you want 
information on plugins or dll's that i have installed on each system? 
just tell me what and where to find them. thanks.

Comment 4

16 years ago
yes marc please.  that information can be found by typing in:

about:plugins

in the URL bar.

I am trying to reproduce this right now with adobe acrobat, both versions.

anthonyd

Comment 5

16 years ago
Okay, now I am posting my results:

okay, i cant seem to find a version older that 5.0.5 anywhere, so I only tested 
with 5.0.5.

using the given url, i was able to open the page just fine with the mozilla 5-
14-2002 build on windows 2000 and windows 98.  I dont have Me or XP to test on.

I am going to wait for the reporter's plugin information before taking further 
action on this bug (either confirm of WFM it).

anthonyd
(Assignee)

Comment 6

16 years ago
Hey Tony:

Win platforms:
win95, win98, SE or ME -- one of those platforms hits all 4
winNT and 2K (and XP for the most part) -- one of those platforms hits all three

When I select the link, I get a dialog noting a SW License Agreement for
SVGReader_WWEULA_English_08.09.01_11:15
(Assignee)

Comment 7

16 years ago
if I accept the agreement, the page loads just fine. And since I can't get that
dialog back since I accpeted it, I am not sure what happens if I declined.
(Reporter)

Comment 8

16 years ago
Here is plugin information for win2k box at home:
    File name: C:\Program Files\mozilla.org\Mozilla\plugins\nppdf32.dll
Adobe Acrobat Plug-In Version 5.00 for Netscape

one thing i did notice was that the acrobat 4.0 box would come up when opening
that page and then the crash would occur. strange i thought - i have acobat 4.0
and reader 5.05 installed. if i open reader 5.05 and leave it open (no open
document) and then try and open the page it works - close reader 5.05 and try it
and crash-city. i uninstalled all versions of reader and acrobat - rebooted -
installed just reader 5.05 - it works. install acrobat 4.0 and the crash starts
happening again. another note is that after installing 4.0 over reader 5.05
reader 5.05 will always ask me if i want to correct my browser plugin for pdfs
(says it is not correct and may not work correctly) i say yes but unless i have
reader 5.05 open while trying to access that link acrobat 4.0 will try and open
the pdf inline with the browser and then crash. right now i am running with just
reader 5.05 and NO acrobat 4.0 - all seems well in my small little world. seems
to be a conflict between reader 5.05 and acrobat 4.0 and who gets to open pdfs
for the web browser. just a side note all seemed fine in netscape 4.79 and ms
exploder 5.50sp2. i will update the bug report with my installed version on work
computer (win98se) with both reader 5.05 and acrobat 4.0 installed.
(Reporter)

Comment 9

16 years ago
on a seperate note - if you install reader 5.05 the first time you launch it
there is a license agreement - if you say no and message appears at the bottom
of the browser (usually where document done is) and says acorbat closed the pdf
hit refresh - if you hit refresh the agreement comes up again. you have to hit
yes on the agreement before you can display any pdfs - this is true if rreading
pdf alone or from within a browser. just say a comment a little further up in
this bug thread and thought i would confirm this for all.
(Reporter)

Comment 10

16 years ago
here is the plugin information for my work computer:
    File name: C:\Program Files\Adobe\Acrobat 5.0\Reader\browser\nppdf32.dll
Adobe Acrobat Plug-In Version 5.00 for Netscape

work computer is win98se with acrobat 4.0 and reader 5.05 installed. it DOES
open that url just fine and the splash screen that comes up when it is opening
says acrobat 4.0 - so it looks like some kind of win2k / acrobat 4.0 / reader
5.05 issue.
(Assignee)

Comment 11

16 years ago
Hi Marc: very strange, it looks like the app knows the plug-in s there and it 
looks like the path is correct. I should have asked this and didn't -- but, 
could you look at the dll and note the version number:
- go to Program Files\Adobe\Acrobat 5.0\Reader\Browser
- select the nppdf32.dll and display the properties
- select Version
on the version panel can you please tell me what the File version is?

Do you have anything else running at the time? Radio or anything? Are you using 
tabs or just the one window? DO you have anything special in your sidebar? I'm 
trying to figure out just what is different. Oh, how are you connected to the 
net from home?

Comment 12

16 years ago
Folks at Netscape:  I am taking a look a this.   

This feels suspicious to me:
"seems
to be a conflict between reader 5.05 and acrobat 4.0 and who gets to open pdfs
for the web browser. just a side note all seemed fine in netscape 4.79 and ms
exploder 5.50sp2. "

Our web browser plug-in will always prefer to open the full Acrobat 
over the reader product, even if the full Acrobat is older.  Note, however,
that the Acrobat Netscape plug-in being used is the 5.0 version, not
the 4.0 version.  I am, therefore, suspecting that a bug fix in the 5.0
version of the acrobat netscape plug-in must be tickling something with this 
configuration.

In any case, stay tuned ...
(Reporter)

Comment 13

16 years ago
in response to ------- Additional Comment #11 From beppe@netscape.com 2002-05-15
08:58 -------

on the work computer (win98se):
nppdf32.dll version is 5.0.5.2001091000

i have no tabs - no sidebar - and i am connected at work via t1 (via dsl at
home). running pretty much that same stuff in background (norton av etc.) BUT no
other applications are open and running when i have been tracking this down -
most of the time i try something then do a reboot and try again.

i will send the dll version from the home computer (win2k) later today.
(Assignee)

Updated

16 years ago
Whiteboard: [ACROBAT?]

Comment 14

16 years ago
Well, folks, using the 2002051408 trunk build and the user's exact Acrobat
configuration (full Acrobat and Acrobat 5.05 reader + Acrobat 5.0 netscape
plug-in) on Win2k, I am UNABLE to duplicate the crash. 

Not only did I try the URL above, I tried several others.

WFM.

Comment 15

16 years ago
Well, folks, using the 2002051408 trunk build and the user's exact Acrobat
configuration (full Acrobat 4.0  and Acrobat 5.05 reader + Acrobat 5.0 netscape
plug-in) on Win2k, I am UNABLE to duplicate the crash. 

Not only did I try the URL above, I tried several others.

WFM.

Comment 16

16 years ago
Going to ask Acrobat QE to attempt to duplicate since I can not.
(Reporter)

Comment 17

16 years ago
in response to:
------- Additional Comments From lmcquarr@adobe.com  2002-05-15 11:53 -------
Well, folks, using the 2002051408 trunk build and the user's exact Acrobat
<SNIP>

i am using build 2002051006 of mozilla 1.0rc2 - would that make a difference?

(Assignee)

Comment 18

16 years ago
yes, that could be a reason why there are two differing results -- shrir can you
test this on the branch build, I tested it on the 1.0.0 branch build and could
not duplicate it.

Comment 19

16 years ago
loads just fine (pr1;0512)

Comment 20

16 years ago
Hi Folks:

This is can not be duplicated by Adobe QE either.

Suggestions from our QE: 
1. Check PDF file association on the machine. With Acrobat 4.0 and Reader 5.05 
installed, Acrobat 4.0 should be associated with all PDF files.
2. Duplicate on more than one machine.
3. Test prior version of Netscape on the machine that crashes.  Does a
Nav 4.X crash also?



Comment 21

16 years ago
BTW -- Adobe QE used 1.0rc2 also for their test. 

Marc -- can you try nav 4.X on the machine that is crashing?
(Reporter)

Comment 22

16 years ago
in response to: ------- Additional Comments From beppe@netscape.com  2002-05-15
08:58 -------
the version of nppdf32.dll on my home win2k box is 5.0.5.452
(Reporter)

Comment 23

16 years ago
in response to: ------- Additional Comment #21 From lmcquarr@adobe.com
2002-05-15 14:01 -------

ok i loaded communicator 4.79 base install on my win2k box and opened that url
no problem - mind you at this point i could open that url no problem with
mozilla 1.0rc2 (build 2002051006) - i only had acrobat reader 5.05 with search
loaded at the time.

so now the test - i reload acrobat 4.0 - reboot - try that url and it now
crashes with both 4.79 and 1.0rc2. i check the version of nppdf32.dll in the
acrobat 4.0 browser folder and it is version 1.0.0.1 (this is a different
version than what is in the reader 5.0 browser folder (see previous bug entry
for exact version).

i uninstall acrobat 4.0 - try the url again and this time 1.0rc2 stops with a
message at the bottom of the browser 'starting plugin for type application/pdf'
and just sits there - i close 1.0rc2 and try the url in 4.79 and get a pop-up
error dialog box 'could not load the plug-in 'adobe acrobat' for the MIME type
'application/pdf'. make sure enough memory is available and that the plug-in is
installed correctly.

i reboot the machine (had NOT reboot since uninstalling acrobat 4.0) - same
errors messages as above. i reinstall reader 5.05 with search and now url works
in both 1.0rc2 and 4.79.

so something about installing acrobat 4.0 and reader 5.05 on my win2k box is
making those browsers crazy. not a big deal for me as i will most likely go with
acrobat 4.0 (cant afford to get 5.0 right now) and uninstall reader 5.05 - but i
am sure i will start running into pdf version issues down the road.

i hope i have not rambled too much - let me know if you need anything else.

Comment 24

16 years ago
WFM Mozilla 1.0RC2 on Win Me
with Reader 5.05 installed- no Acrobat 4.0 installed

Comment 25

16 years ago
Hi Marc and Mozilla Folks:

In response to  ------- Additional Comment #23 From marc schuette 2002-05-15 
21:02 -------

"so now the test - i reload acrobat 4.0 - reboot - try that url and it now
crashes with both 4.79 and 1.0rc2."

Here is my opinion:

1 - Adobe QE extensively tests installation configurations similar to Marks --
that being there is more than one version of Acrobat on a user's machine,
and the full Acrobat product is an older version.  (As I mentioned, 
our browser plug-in will prefer to run a full Acrobat product over an installed
reader, even if the full Acrobat is an older version.)

2 - Clearly, however, there is some bug somewhere (duh ... it crashes, right?)

3 - It crashes BOTH NS 4.7X and Mozilla.  This means that the bug is ***not***
something that was introduced by mozilla.  It is a bug in Adobe Acrobat
code.   

Conclusions to mozilla folks: 

I believe this can be closed as "not our bug"

To Marc:

It sounds like you have a solution you can live with now.  I am going to
ask Adobe product marketing to add you to the beta list for a soon-to-be
forthcoming Acrobat reader beta.  If you are interested, you will need
to return the materials as instructed.  With this beta, you can try
out your configuration again and we can see if the problem still
exists.  If it does, you will be in the loop to get it fixed. 

How does this sound?

P.S. Thank you all for all of the leg work you have done.
(Reporter)

Comment 26

16 years ago
inresponse to:
------- Additional Comments From lmcquarr@adobe.com  2002-05-16 07:14 -------

Hi Marc and Mozilla Folks:<SNIP>

ok sounds good - i'll go an bang on mozilla some more now :-)

keep up the great work - the browser really shows promise!

Comment 27

16 years ago
Liz, u are great ! Marking this wontfix..
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
Whiteboard: [ACROBAT?] → [ACROBAT BUG]

Comment 28

16 years ago
marking verif, pls reopen stating a reason, Thx!
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Plug-ins → PDF (Adobe)
Product: Core → Plugins
QA Contact: shrir → adobe-reader
Version: Trunk → unspecified
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.