Firefox Accounts is searchable in about:preferences when disable sync policy is in use

VERIFIED FIXED in Firefox 60

Status

()

defect
P1
normal
VERIFIED FIXED
a year ago
a year ago

People

(Reporter: Abe_LV, Assigned: eoger)

Tracking

60 Branch
Firefox 61
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox60+ verified, firefox61 verified)

Details

Attachments

(1 attachment)

Reporter

Description

a year ago
Steps to reproduce:
Screen capture is here- https://testing-1.tinytake.com/sf/MjQxNDMxNl83MzE3Mzkx

1- disable sync using the following:
{
  "policies": {
    "DisableFirefoxAccounts": true
  }
}

2- Restart the browser and go to about:preferences
3- Search "sync" in "Find in Options" text box.
4. Observe the result

Actual result:
Firefox Accounts options are displayed, [Sign In] button is not greyed out and "Get Started" link looks active.

Expected result:
Sync is not searchable once disabled
Reporter

Updated

a year ago
Flags: needinfo?(felipc)
Eoger, so it turns out that the identity.fxaccounts.enabled pref just hides the Firefox Account section from the left sidebar, but doesn't prevent it from showing up while searching. See screen capture. Could you take a look on this?
Component: Enterprise Policies → Sync
Flags: needinfo?(felipc) → needinfo?(eoger)
There's a data-hidden-from-search attribute to be used for this
Assignee

Updated

a year ago
Assignee: nobody → eoger
Status: NEW → ASSIGNED
Flags: needinfo?(eoger)
Priority: -- → P1
Assignee

Comment 4

a year ago
We should uplift this if this is fixed after the merge.

Comment 5

a year ago
mozreview-review
Comment on attachment 8957644 [details]
Bug 1443593 - Remove FxA preferences from search results when FxA is disabled.

https://reviewboard.mozilla.org/r/226552/#review232952
Attachment #8957644 - Flags: review?(markh) → review+
[Tracking Requested - why for this release]:
Needed for the enterprise policies feature: follow-up to the Disable Sync policy

Comment 7

a year ago
Pushed by eoger@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/294b15b9d3c0
Remove FxA preferences from search results when FxA is disabled. r=markh
Assignee

Updated

a year ago
Blocks: 1434706

Comment 8

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/294b15b9d3c0
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
Comment on attachment 8957644 [details]
Bug 1443593 - Remove FxA preferences from search results when FxA is disabled.

Approval Request Comment
[Feature/Bug causing the regression]: Enterprise Policies
[User impact if declined]: This is a follow-up to the "Disable Sync" policy. When in use, the Sync pane disappears from about:preferences. However, it can still show up if someone uses the search box from the Preferences page. This bug fixes that.
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: QA has verified the fix
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: Not risky because it was just missing an attribute that is used with this purpose (hiding from the search feature in about:preferences)
[String changes made/needed]: none
Attachment #8957644 - Flags: approval-mozilla-beta?
Comment on attachment 8957644 [details]
Bug 1443593 - Remove FxA preferences from search results when FxA is disabled.

fix for DisableFirefoxAccounts policy, beta60+
Attachment #8957644 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Reporter

Comment 12

a year ago
We tested this on beta60 and Nightly 61 and it is verified as fixed.
sync is not searchable when 'disable sync' policy is in use.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.