checkbox and radio style

RESOLVED WONTFIX

Status

()

--
minor
RESOLVED WONTFIX
17 years ago
13 years ago

People

(Reporter: micval, Assigned: rods)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Since 1.0-rc1 checkbox and radio buttons have had problem with border-style. The
specified style is used only when element has focus, otherwise it is displayed
with default border-style. Other attributes (border-color, background-color..)
seem to act consistenly.

Comment 1

17 years ago
See discussions in bug 106317 and bug 134927
->HTML Form Controls
Assignee: dbaron → rods
Component: Style System → HTML Form Controls
QA Contact: ian → tpreston
This was done on purpose, since some border-styles (eg "none") make checkboxes
and radio buttons invisible and are somewhat commonly used out there.

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All

Comment 4

17 years ago
Allowing authors to change the border style also interferes with keyboard 
navigation. Checkbox focus is conveyed through border style, and if this border 
style remains constant because an author did not specify a different :focus 
rule, there is no way to tell whether or not the checkbox has focus.

marking WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX

Comment 5

13 years ago
(In reply to comment #4)
> Allowing authors to change the border style also interferes with keyboard 
> navigation. Checkbox focus is conveyed through border style, and if this border 
> style remains constant because an author did not specify a different :focus 
> rule, there is no way to tell whether or not the checkbox has focus.
> 
> marking WONTFIX.

But why do you believe that you should make that decision for the authors of the webpages? Why not let them determine what is necessary to get correct focus behavior etc, instead of enforcing those annoying borders on everyone?

If someone develops somehting unusable, he will fix it, or the users will complain or go away. IMHO, that is just not something that the browser should be concerned with at all.
> If someone develops somehting unusable, he will fix it

A number of very very popular sites were unusable if we allowed border styling.  Shipping that way was simply unacceptable -- users would assume the browser is buggy, not the site, and simply not use the browser.
You need to log in before you can comment on or make changes to this bug.