The button "Open Screenshots Website" in "Let's get started" tour in Firefox Developer Edition does not work.

RESOLVED FIXED in Firefox 60

Status

()

defect
P1
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: dedifferentiator, Assigned: MattN)

Tracking

({regression})

60 Branch
Firefox 60
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox58 unaffected, firefox59 unaffected, firefox60 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180302190033

Steps to reproduce:

1.Downloaded Firefox Developer Edition.
2.Pressed the button "New to Firefox Developer Edition? Let’s get started."
3.After "Private browsing" block, pressed the button "Open Screenshots Website" in "Screenshots"  block, then nothing happened.
4.Closed "Let's get started", opened it again, repeated actions, nothing has changed.


Actual results:

Nothing


Expected results:

Should have opened "Screenshots Website".
(Reporter)

Updated

a year ago
Summary: Do not works button "Open Screenshots Website" in "Let's get started" tour in Firefox Developer Edition. → Do not work button "Open Screenshots Website" in "Let's get started" tour in Firefox Developer Edition.
(Reporter)

Updated

a year ago
Summary: Do not work button "Open Screenshots Website" in "Let's get started" tour in Firefox Developer Edition. → The button "Open Screenshots Website" in "Let's get started" tour in Firefox Developer Edition does not work.
Can confirm on Firefox Nightly built March 8th, 2018, on macOS El Capitan 10.11.6, in a brand-new profile. Can you edit the component to put this in the "Tours" component of the Firefox product? Thanks!
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

a year ago
Based on comment 1 I'll set this to "Tours" component.
Component: Untriaged → Tours
This looks like a clear regression where a <button> was used in bug 1433929 instead of an <a>.
Assignee: nobody → MattN+bmo
Blocks: 1433929
Status: NEW → ASSIGNED
Keywords: regression
Priority: -- → P1

Comment 5

a year ago
mozreview-review
Comment on attachment 8957761 [details]
Bug 1443632 - Change screenshots tour action button back to an <a>.

https://reviewboard.mozilla.org/r/226742/#review232528

Matt and I talked about this in person, and agreed that adding an automated test would make the patch riskier to uplift, given that "https://screenshots.firefox.com/#tour" is hard-coded as the button URL. This is a minimally invasive fix.
Attachment #8957761 - Flags: review?(kit) → review+

Comment 6

a year ago
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/a28f113ffa3f
Change screenshots tour action button back to an <a>. r=kitcambridge

Comment 7

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/a28f113ffa3f
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 60
You need to log in before you can comment on or make changes to this bug.