Closed Bug 1443683 Opened 2 years ago Closed 9 months ago

Drag and Drop may not work on OOP IFrames

Categories

(Core :: DOM: Drag & Drop, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla69
Fission Milestone M3
Tracking Status
firefox69 --- fixed

People

(Reporter: qdot, Assigned: enndeakin)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 2 obsolete files)

STR

- Select text in an iframe
- Try to drag it to either root document or other iframe

Expected:

Dragging works, text moves with cursor

Actual: 

Either drag is ignored, or whole iframe is dragged.
This could use a test case. With data:text/html;charset=utf-8,<iframe src="https://hsivonen.fi"></iframe> , I can drag text from the iframe.
Flags: needinfo?(kyle)
Priority: -- → P3
Dialing this back to "may not work", assigning to myself so I'll remember to check it, and moving back to P4. We've got enough going on in the architecture changes that by the time we get around to actually OOP'ing iframes, who knows what things will look like.
Assignee: nobody → kyle
Flags: needinfo?(kyle)
Priority: P3 → P4
Summary: Drag and Drop does not work on OOP IFrames → Drag and Drop may not work on OOP IFrames
Blocks: fission-frontend
No longer blocks: oop-frames, fission

Neil, could you please look into this?

Assignee: kyle → nobody
Fission Milestone: --- → ?
Flags: needinfo?(enndeakin)
Priority: P4 → P3
Fission Milestone: ? → M3
Assignee: nobody → enndeakin
Flags: needinfo?(enndeakin)
Component: DOM: Core & HTML → Drag and Drop
Status: NEW → ASSIGNED
Depends on: 1550800
Attachment #9064782 - Attachment is obsolete: true
Depends on: 1555138
No longer depends on: 1555138
Attachment #9067112 - Attachment description: Bug 1443683, support drag and drop in out of process frames; this is done by storing the drag information about the data to be dragged and visualization image in the event state manager instead of the BrowserParent and passing this information on... → Bug 1443683, support drag and drop in out of process frames; this is done by storing the drag information about the data to be dragged and image in the event state manager instead of BrowserParent, passing this information on to the drag service, r?nika
Attachment #9068371 - Attachment is obsolete: true
Pushed by neil@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/dd61d5c2a773
support drag and drop in out of process frames; this is done by storing the drag information about the data to be dragged and visualization image in the event state manager instead of the BrowserParent and passing this information on to the drag service, r=nika
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

mozregression led me here, because I was trying to figure out why I can't see dragged text anymore with 69.0a1 (2019-06-03) (64-bit) on Gentoo Linux.

Adding ni for Neil to look into the regression reported in comment 9.

Flags: needinfo?(enndeakin)

Looks like some lines got lost during a patch update. I'll re-add them.

Flags: needinfo?(enndeakin)
Pushed by neil@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/aee192adb1de
followup to fix drag feedback images, re-add lines that got lost in the last patch, r=nika
Flags: qe-verify+
QA Contact: vlad.lucaci
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.