Acrobat plugin overrides helper app preference

VERIFIED DUPLICATE of bug 19118

Status

()

Core
Plug-ins
VERIFIED DUPLICATE of bug 19118
16 years ago
16 years ago

People

(Reporter: Olli Männistö, Assigned: rubydoo123)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
With Mozilla RC2, I started getting PDF files opened into browser window again.
Previously, I had configured both IE and Mozilla to fire acrobat reader as an
external reader by setting the helper app preference. Apparently Mozilla now
scans registry/disk for supported plugins. Acrobat plugin resides in the acrobat
directory, not mozilla plugin directory. I have configured acrobat reader NOT to
support in-browser viewing but mozilla does not honor this option. 

I have to read many, many pdf databooks every day, so it's simply not acceptable
to have the acrobat plugin crash on me every five datasheets or so. As an
external reader, it almost never crashes.

Steps:
1. open a datasheet (http://www.onsemi.com/pub/Collateral/2N4401-D.PDF)

Expected result:
Acrobat starts as an external helper app

Actual result:
Acrobat starts as a browser plugin

Reproducibility:
Always.
Duplicate of "Plug-In Manager (ui for choosing mimetype-plugin associations)"

*** This bug has been marked as a duplicate of 19118 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
v, Thx, Boris.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

16 years ago
Are you sure you're not confusing issues? 
I'm talking about plugin overriding whatever I've specified in the "helper
applications" section of the Navigator preferences. Should explicit definition
of a helper app override use of a plugin, not the other way around?
You need to log in before you can comment on or make changes to this bug.