Closed Bug 1443935 Opened 2 years ago Closed 2 years ago

browser_updatesCantApply.js fails when run with the ability to elevate

Categories

(Toolkit :: Application Update, enhancement)

59 Branch
enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla60
Tracking Status
firefox60 --- fixed

People

(Reporter: robert.strong.bugs, Assigned: robert.strong.bugs)

Details

Attachments

(1 file)

If the client running the test can elevate the check of the file in the app dir that is locked is skipped.

https://dxr.mozilla.org/mozilla-central/source/toolkit/mozapps/update/nsUpdateService.js#431

Similar to bug 1438423 from mochitest-browser-chrome
Attached patch patch rev1Splinter Review
Assignee: nobody → robert.strong.bugs
Status: NEW → ASSIGNED
Attachment #8956968 - Flags: review?(mhowell)
Attachment #8956968 - Flags: review?(mhowell) → review+
Pushed by rstrong@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/01d346536b69
make it so browser_updatesCantApply.js test passes when it is run with the ability to elevate. r=mhowell
https://hg.mozilla.org/mozilla-central/rev/01d346536b69
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
You need to log in before you can comment on or make changes to this bug.