Closed Bug 1444088 Opened 3 years ago Closed 3 years ago

review link for patches on the requests page no longer shows up

Categories

(bugzilla.mozilla.org :: Splinter, defect)

Production
defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: froydnj, Assigned: kohei.yoshino)

References

Details

(Keywords: regression)

Attachments

(1 file)

45 bytes, text/x-github-pull-request
dylan
: review+
Details | Review
STR:

1. Go to somebody's requests page; the page below is for the shared review queue for :build-peer.

https://bugzilla.mozilla.org/request.cgi?action=queue&requester=&product=&type=all&requestee=core-build-config-reviews%40mozilla.bugs&component=&group=type&do_union=1

Expected results:

The "Attachment" column contains a [details] link and a [review] link for each patch.

Actual results:

The "Attachment" column contains only a [details] link.

This means to review patches in splinter requires extra clicks from this page, which is inconvenient.  This behavior is a recent regression.
Ugh, that's probably me. sigh :(

In https://github.com/mozilla-bteam/bmo/pull/372 I said `ispatch` "field is not used in other templates so the change should be safe" but there is:

https://github.com/mozilla-bteam/bmo/blob/master/extensions/Splinter/template/en/default/hook/request/queue-after_column.html.tmpl

Will fix it once I get the virtual machine at home.
Assignee: nobody → kohei.yoshino
Blocks: 1429344
Status: NEW → ASSIGNED
Component: General → Extensions: Splinter
Keywords: regression
Thank you!
Attached file pull request
Attachment #8957566 - Flags: review?(dylan)
Attachment #8957566 - Flags: review?(dylan) → review+
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
I'm still seeing this, but I assume this is actually fixed and simply not yet pushed to the actual bugzilla instance?
Flags: needinfo?(kohei.yoshino)
Yes, this is not live yet. I'm sure when it goes production.
Flags: needinfo?(kohei.yoshino)
I mean: not sure...
There was a bit of a delay getting this out because of a large amount of work for the cloud migration. It is now live though.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.