Closed Bug 1444177 Opened 2 years ago Closed 2 years ago

Intermittent dom/animation/test/mozilla/test_restyles.html | Finite transform animation in out-of-view element should never be throttled - got 19, expected 20

Categories

(Core :: DOM: Animation, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla61
Tracking Status
firefox60 --- fixed
firefox61 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: hiro)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Filed by: ncsoregi [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=166731644&repo=autoland

https://queue.taskcluster.net/v1/task/DxIwlDgORTyMuwOn6YCydQ/runs/0/artifacts/public/logs/live_backing.log

[task 2018-03-08T12:24:39.186Z] 12:24:39     INFO - Buffered messages finished
[task 2018-03-08T12:24:39.187Z] 12:24:39     INFO - TEST-UNEXPECTED-FAIL | dom/animation/test/mozilla/test_restyles.html | Finite transform animation in out-of-view element should never be throttled - got 19, expected 20
[task 2018-03-08T12:24:39.188Z] 12:24:39     INFO -     SimpleTest.is@SimpleTest/SimpleTest.js:312:5
[task 2018-03-08T12:24:39.189Z] 12:24:39     INFO -     finite_transform_animations_in_out_of_view_element@dom/animation/test/mozilla/file_restyles.html:602:5
[task 2018-03-08T12:24:39.190Z] 12:24:39     INFO -     async*add_task/</<@SimpleTest/SpawnTask.js:298:21
[task 2018-03-08T12:24:39.191Z] 12:24:39     INFO -     onFulfilled@SimpleTest/SpawnTask.js:69:15
[task 2018-03-08T12:24:39.192Z] 12:24:39     INFO -     promise callback*next@SimpleTest/SpawnTask.js:104:45
[task 2018-03-08T12:24:39.193Z] 12:24:39     INFO -     onFulfilled@SimpleTest/SpawnTask.js:73:7
[task 2018-03-08T12:24:39.194Z] 12:24:39     INFO -     promise callback*next@SimpleTest/SpawnTask.js:104:45
[task 2018-03-08T12:24:39.195Z] 12:24:39     INFO -     onFulfilled@SimpleTest/SpawnTask.js:73:7
[task 2018-03-08T12:24:39.196Z] 12:24:39     INFO -     promise callback*next@SimpleTest/SpawnTask.js:104:45
[task 2018-03-08T12:24:39.198Z] 12:24:39     INFO -     onFulfilled@SimpleTest/SpawnTask.js:73:7
[task 2018-03-08T12:24:39.199Z] 12:24:39     INFO -     promise callback*next@SimpleTest/SpawnTask.js:104:45
[task 2018-03-08T12:24:39.199Z] 12:24:39     INFO -     onFulfilled@SimpleTest/SpawnTask.js:73:7
[task 2018-03-08T12:24:39.200Z] 12:24:39     INFO -     promise callback*next@SimpleTest/SpawnTask.js:104:45
[task 2018-03-08T12:24:39.201Z] 12:24:39     INFO -     onFulfilled@SimpleTest/SpawnTask.js:73:7
[task 2018-03-08T12:24:39.201Z] 12:24:39     INFO -     promise callback*next@SimpleTest/SpawnTask.js:104:45
[task 2018-03-08T12:24:39.202Z] 12:24:39     INFO -     onFulfilled@SimpleTest/SpawnTask.js:73:7
[task 2018-03-08T12:24:39.203Z] 12:24:39     INFO -     promise callback*next@SimpleTest/SpawnTask.js:104:45
[task 2018-03-08T12:24:39.204Z] 12:24:39     INFO -     onFulfilled@SimpleTest/SpawnTask.js:73:7
[task 2018-03-08T12:24:39.205Z] 12:24:39     INFO -     promise callback*next@SimpleTest/SpawnTask.js:104:45
[task 2018-03-08T12:24:39.207Z] 12:24:39     INFO -     onFulfilled@SimpleTest/SpawnTask.js:73:7
[task 2018-03-08T12:24:39.208Z] 12:24:39     INFO -     promise callback*next@SimpleTest/SpawnTask.js:104:45
[task 2018-03-08T12:24:39.208Z] 12:24:39     INFO -     onFulfilled@SimpleTest/SpawnTask.js:73:7
[task 2018-03-08T12:24:39.209Z] 12:24:39     INFO -     promise callback*next@SimpleTest/SpawnTask.js:104:45
[task 2018-03-08T12:24:39.210Z] 12:24:39     INFO -     onFulfilled@SimpleTest/SpawnTask.js:73:7
[task 2018-03-08T12:24:39.210Z] 12:24:39     INFO -     promise callback*next@SimpleTest/SpawnTask.js:104:45
[task 2018-03-08T12:24:39.211Z] 12:24:39     INFO -     onFulfilled@SimpleTest/SpawnTask.js:73:7
[task 2018-03-08T12:24:39.212Z] 12:24:39     INFO -     promise callback*next@SimpleTest/SpawnTask.js:104:45
[task 2018-03-08T12:24:39.213Z] 12:24:39     INFO -     onFulfilled@SimpleTest/SpawnTask.js:73:7
[task 2018-03-08T12:24:39.214Z] 12:24:39     INFO -     promise callback*next@SimpleTest/SpawnTask.js:104:45
[task 2018-03-08T12:24:39.215Z] 12:24:39     INFO -     onFulfilled@SimpleTest/SpawnTask.js:73:7
[task 2018-03-08T12:24:39.215Z] 12:24:39     INFO -     promise callback*next@SimpleTest/SpawnTask.js:104:45
[task 2018-03-08T12:24:39.216Z] 12:24:39     INFO -     onFulfilled@SimpleTest/SpawnTask.js:73:7
[task 2018-03-08T12:24:39.217Z] 12:24:39     INFO -     promise callback*next@SimpleTest/SpawnTask.js:104:45
[task 2018-03-08T12:24:39.217Z] 12:24:39     INFO -     onFulfilled@SimpleTest/SpawnTask.js:73:7
[task 2018-03-08T12:24:39.218Z] 12:24:39     INFO -     promise callback*next@SimpleTest/SpawnTask.js:104:45
[task 2018-03-08T12:24:39.219Z] 12:24:39     INFO -     onFulfilled@SimpleTest/SpawnTask.js:73:7
[task 2018-03-08T12:24:39.220Z] 12:24:39     INFO -     co/<@SimpleTest/SpawnTask.js:58:5
[task 2018-03-08T12:24:39.221Z] 12:24:39     INFO -     co@SimpleTest/SpawnTask.js:54:10
[task 2018-03-08T12:24:39.221Z] 12:24:39     INFO -     setTimeout handler*add_task@SimpleTest/SpawnTask.js:271:7
[task 2018-03-08T12:24:39.222Z] 12:24:39     INFO -     @dom/animation/test/mozilla/file_restyles.html:161:3
[task 2018-03-08T12:24:39.223Z] 12:24:39     INFO -     waitForPaints@SimpleTest/paint_listener.js:77:5
[task 2018-03-08T12:24:39.226Z] 12:24:39     INFO -     waitForPaints/<@SimpleTest/paint_listener.js:65:22
[task 2018-03-08T12:24:39.227Z] 12:24:39     INFO -     setTimeout handler*paintListener@SimpleTest/paint_listener.js:32:7
[task 2018-03-08T12:24:39.228Z] 12:24:39     INFO -     EventListener.handleEvent*@SimpleTest/paint_listener.js:35:3
[task 2018-03-08T12:24:39.228Z] 12:24:39     INFO -     @SimpleTest/paint_listener.js:1:2
[task 2018-03-08T12:24:39.229Z] 12:24:39     INFO - SpawnTask.js | Leaving test finite_transform_animations_in_out_of_view_element
[task 2018-03-08T12:24:39.230Z] 12:24:39     INFO - SpawnTask.js | Entering test restyling_main_thread_animations_in_scrolled_out_element
[task 2018-03-08T12:24:39.231Z] 12:24:39     INFO - TEST-PASS | dom/animation/test/mozilla/test_restyles.html | Animations running on the main-thread for elements which are scrolled out should never cause restyles
I guess this is caused by bug 1437272.
Depends on: 1437272
Yeah, I am pretty sure the test case is flaky in the first place.  I think the failure reason is that the animation in question just started at the current timeline time, so the first style was skipped there as we've been seeing in other test cases.  I am inclined to add waitForAnimationReadyToRestyle and use it in all test cases in test_restyles.html.  Anyway I will cleanup test_restyles.html in bug 1425778 once Firefox 60 branch has been branched.  I will probably add waitForAnimationReadyToRestyle there.
I will take care of this.
Assignee: nobody → hikezoe
Status: NEW → ASSIGNED
https://treeherder.mozilla.org/#/jobs?repo=try&revision=907a838b7a32ab6a5cdc1b0e116a77d4fe605f0f

I've decided not introduce waitForAnimationReadyToRestyle for this failure since it also needs to drop tweakExpectedRestyleCount (bug 1425778 which requires the microtask change), and it might be possible that the microtask change gets backed out (there is a crash bug (bug 1443429) and a bug (bug 1446644) which breaks extensions), whereas the fix for this failure should be definitely uplifted to beta with/without the microtask change.  Anyway, just in case.
Comment on attachment 8960059 [details]
Bug 1444177 - Tweak expected restyle count for the test case where finite animation is unthrottled in out-of-view element.

https://reviewboard.mozilla.org/r/228838/#review234514
Attachment #8960059 - Flags: review?(bbirtles) → review+
Pushed by hikezoe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c8f111ec6150
Tweak expected restyle count for the test case where finite animation is unthrottled in out-of-view element. r=birtles
https://hg.mozilla.org/mozilla-central/rev/c8f111ec6150
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Depends on: 1447134
You need to log in before you can comment on or make changes to this bug.