TextSelection and InputCursor are not visible in Mozillas URL-Input-Field!

CLOSED WORKSFORME

Status

()

Core
Editor
CLOSED WORKSFORME
16 years ago
15 years ago

People

(Reporter: Frank Jiranek, Assigned: kinmoz)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
If you load the URL:
http://www.ep.haufe.de/~jiranek/ScrollingSimpleApplet/ScrollingSimple.html the
TextSelection works fine. But if you Select a Text in the TextField of the
Applet (this is a original Applet-Example of the Java-Tutorial called
"ScrollingSimple") and then press the Reload-Button of Mozilla and then if you
select text in the URL-Field of Mozilla the TextSelection and the InputCursor
are not visible, and in the Input-Text-Field of the Form in this page the
TextSelection is visible, but not the InputCursor. If you bring another
Application-Window to the front and then the Mozilla-Window to the front again,
then the TextSelection works normal again. If you want to get the sources of
this test, just use this URL: http://www.ep.haufe.de/~jiranek/ScrollingSimpleApplet.
My testing environment is Win2000/pro, Mozilla/2002051006 and JRE 1.3.1_02.

Comment 1

16 years ago
To clarify (I've to read it a few times before I got it ;-)
1. Load http://www.ep.haufe.de/~jiranek/ScrollingSimpleApplet/ScrollingSimple.html
2. Select a piece of text in the applet (bottom, grey) text field
3. Hit mozilla's reload button
4. Click in mozilla's URL field -> No cursor shown
5. Select a part of the URL -> No selection shown
6. Click in the text input (upper) field -> No cursor shown
7. Bring another application to the front
8. Bring mozilla to front again: everything is normal again

Can confirm this for Build 2002051408 on WinMe/jre 1.3.1_03
(Reporter)

Comment 2

16 years ago
I have found a command sequence to reproduce this bug with mozilla 1.0.0 and
sun’s jre 1.4.0!
1.  Load http://www.ep.haufe.de/~jiranek/ScrollingSimpleApplet/ScrollingSimple.html
2.  open the java-console
3.  bring the mozilla to the front again (click in the dragbar)
4.  Select a piece of text in the applet (bottom, grey) text field
5.  click in the java-console window
6.  bring the mozilla window to the front (click in the dragbar)
7.  Hit mozilla's reload button
8.  Click in mozilla's URL field -> No cursor shown
9.  Select a part of the URL -> No selection shown
10. Click in the text input (upper) field -> No cursor shown
11. Bring another application to the front
12. Bring mozilla to front again: everything is normal again

I hope you can reproduce this bug.
-> Editor:Core
Assignee: Matti → kin
Component: Browser-General → Editor: Core
QA Contact: imajes-qa → sujay
(Reporter)

Comment 4

16 years ago
I can not reproduce this bug with Mozilla 1.0.1!
Thus this bug must be fixed!

Comment 5

16 years ago
And I can't reproduce it in Win2K 20021114. So, WFM! (Which means that it was
probably fixed!)

-M
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 6

16 years ago
verified.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

15 years ago
I Can NOT reproduce this bug with current environments,
thus is was fixed =>  Set status to Closed.
Status: VERIFIED → CLOSED
You need to log in before you can comment on or make changes to this bug.