Permafailing leakcheck | default process: 685525 bytes leaked (Annotators, Array, AsyncFreeSnowWhite, AsyncLatencyLogger, BackstagePass, ...)

RESOLVED FIXED in Firefox 61

Status

()

defect
RESOLVED FIXED
Last year
Last year

People

(Reporter: intermittent-bug-filer, Assigned: pauly)

Tracking

({intermittent-failure, memory-leak, regression})

unspecified
Firefox 61
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox59 unaffected, firefox60 wontfix, firefox61 fixed)

Details

(Whiteboard: [stockwell disabled])

Attachments

(1 attachment)

Filed by: ncsoregi [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=166817302&repo=mozilla-central

https://queue.taskcluster.net/v1/task/GBwNOWCIRau2KaI1YfMtTw/runs/0/artifacts/public/logs/live_backing.log

19:55:29     INFO -  1063 INFO TEST-START | docshell/test/browser/browser_uriFixupIntegration.js
19:55:29     INFO -  GECKO(3012) | --DOCSHELL 000001A54A7ED800 == 6 [pid = 3424] [id = {08ffd548-ed98-4fca-a2ba-aecde1ad9bae}]
[...]
19:50:01    ERROR -  876 ERROR TEST-UNEXPECTED-FAIL | leakcheck | default process: 685525 bytes leaked (Annotators, Array, AsyncFreeSnowWhite, AsyncLatencyLogger, BackstagePass, ...)
19:50:01     INFO -  == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 2012
19:50:01     INFO -       |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
19:50:01     INFO -       |                                      | Per-Inst   Leaked|   Total      Rem|
19:50:01     INFO -     0 |TOTAL                                 |       43        0|  169187        0|
19:50:01     INFO -  nsTraceRefcnt::DumpStatistics: 994 entries
19:50:01     INFO -  TEST-PASS | leakcheck | tab process: no leaks detected!
19:50:01     INFO -  == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 5168
19:50:01     INFO -       |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
19:50:01     INFO -       |                                      | Per-Inst   Leaked|   Total      Rem|
19:50:01     INFO -     0 |TOTAL                                 |       40        0|  256174        0|
19:50:01     INFO -  nsTraceRefcnt::DumpStatistics: 1011 entries
19:50:01     INFO -  TEST-PASS | leakcheck | tab process: no leaks detected!
19:50:01     INFO -  == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 7472
19:50:01     INFO -       |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
19:50:01     INFO -       |                                      | Per-Inst   Leaked|   Total      Rem|
19:50:01     INFO -     0 |TOTAL                                 |       43        0|  218513        0|
19:50:01     INFO -  nsTraceRefcnt::DumpStatistics: 1063 entries
19:50:01     INFO -  TEST-PASS | leakcheck | tab process: no leaks detected!
19:50:01     INFO -  == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 8008
19:50:01     INFO -       |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
19:50:01     INFO -       |                                      | Per-Inst   Leaked|   Total      Rem|
19:50:01     INFO -     0 |TOTAL                                 |       36        0| 1535217        0|
19:50:01     INFO -  nsTraceRefcnt::DumpStatistics: 1179 entries
19:50:01     INFO -  TEST-PASS | leakcheck | tab process: no leaks detected!
There are 31 failures since this bug was created (4 days), all of them occurred on windows10-64-ccov debug.
Recent log failure: https://treeherder.mozilla.org/logviewer.html#?repo=mozilla-central&job_id=167418234&lineNumber=12316
Relevant part of the log:
15:22:14    ERROR -  583 ERROR TEST-UNEXPECTED-FAIL | leakcheck | default process: 682453 bytes leaked (Annotators, Array, AsyncFreeSnowWhite, AsyncLatencyLogger, BackstagePass, ...)
15:22:14     INFO -  == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 1312
15:22:14     INFO -       |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
15:22:14     INFO -       |                                      | Per-Inst   Leaked|   Total      Rem|
15:22:14     INFO -     0 |TOTAL                                 |       48        0|  115865        0|
15:22:14     INFO -  nsTraceRefcnt::DumpStatistics: 1000 entries
15:22:14     INFO -  TEST-PASS | leakcheck | tab process: no leaks detected!
15:22:14     INFO -  == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 5516
15:22:14     INFO -       |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
15:22:14     INFO -       |                                      | Per-Inst   Leaked|   Total      Rem|
15:22:14     INFO -     0 |TOTAL                                 |       45        0|  189006        0|
15:22:14     INFO -  nsTraceRefcnt::DumpStatistics: 1157 entries
15:22:14     INFO -  TEST-PASS | leakcheck | tab process: no leaks detected!
15:22:14     INFO -  == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 7044
15:22:14     INFO -       |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
15:22:14     INFO -       |                                      | Per-Inst   Leaked|   Total      Rem|
15:22:14     INFO -     0 |TOTAL                                 |       35        0| 1634302        0|
15:22:14     INFO -  nsTraceRefcnt::DumpStatistics: 1021 entries
15:22:14     INFO -  TEST-PASS | leakcheck | tab process: no leaks detected!
15:22:14     INFO -  == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 7208
15:22:14     INFO -       |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
15:22:14     INFO -       |                                      | Per-Inst   Leaked|   Total      Rem|
15:22:14     INFO -     0 |TOTAL                                 |       44        0|  210156        0|
15:22:14     INFO -  nsTraceRefcnt::DumpStatistics: 1063 entries
15:22:14     INFO -  TEST-PASS | leakcheck | tab process: no leaks detected!
15:22:14     INFO -  runtests.py | Running tests: end.
15:22:14     INFO -  Buffered messages finished
:overholt Can you please take a look?
Flags: needinfo?(overholt)
Andrew is on PTO. It sounds like this is a permanent failure. Can a sheriff bisect what change introduced this? That would make it much easier to fix.

It looks like this leak is happening while running the browser/components/places/tests/browser/ directory. Tests were added to this directory in bug 1443189 and bug 1440703 around when this bug was first filed, so maybe one of those is to blame.

(Just as a side note, the relevant part of the blog is actually before those errors. The part you included only shows things from processes that didn't leak.)
Component: Document Navigation → Bookmarks & History
Product: Core → Firefox
Bug 1440703 seems more likely, because it landed on March 7th, the same day this bug was filed. Bug 1443189 didn't land until the 8th.
Blocks: 1440703
Changed browser.ini so the test skips running on Win10-ccov due to bug 1423667.
Attachment #8958464 - Flags: review?(standard8)
Comment on attachment 8958464 [details] [diff] [review]
skip_win10ccov_for_bug1440703

Review of attachment 8958464 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks.
Attachment #8958464 - Flags: review?(standard8) → review+
Assignee: nobody → paul.silaghi
Status: NEW → ASSIGNED
No push to try needed, since we’re just disabling the test.
Keywords: checkin-needed
Flags: needinfo?(overholt)
Pushed by rgurzau@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/1a6af3324b34
skip win10-ccov in browser.ini for bug 1440703 r=standard8
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/1a6af3324b34
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
No need to backport to 60 since we only run ccov builds/tests on trunk.
Whiteboard: [stockwell unknown] → [stockwell disabled]
You need to log in before you can comment on or make changes to this bug.