Closed Bug 1444244 Opened 5 years ago Closed 5 years ago

Addon's "Preferences" button with options_ui open_in_tab opens tab to right of ALL tabs, rather than next to current tab

Categories

(Toolkit :: Add-ons Manager, enhancement, P5)

58 Branch
enhancement

Tracking

()

VERIFIED FIXED
mozilla61
Tracking Status
firefox61 --- verified

People

(Reporter: xagruiphoi, Assigned: arjunkrishnababu96, Mentored)

Details

(Keywords: good-first-bug)

Attachments

(2 files)

for example, the "Preferences" button listed for Adblock Plus on about:addons opens a new tab all the way to the right of all tabs, rather than being positioned in relation to the current tab. this behavior is inconsistent with tabs opened from websites, which are placed relative to the opening tab.
This should just be a matter of including `relatedToCurrent: true` in the options here:
https://searchfox.org/mozilla-central/rev/588d8120aa11738657da93e09a03378bcd1ba8ec/toolkit/mozapps/extensions/content/extensions.js#1535-1537
Mentor: aswan
Keywords: good-first-bug
Priority: -- → P5
I'd like to work on this.
Assignee: nobody → arjunkrishnababu96
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Comment on attachment 8957423 [details]
Bug 1444244 - Fix location where Addon's "Preferences" tab is opened;

https://reviewboard.mozilla.org/r/226342/#review232826

Looks good, thanks!  Do you have access to try?  Some of the tests in toolkit/mozapps/extensions/test/browser refer to the preferences button, we should make sure none of them are going to break with this change.
Attachment #8957423 - Flags: review?(aswan) → review+
(In reply to Andrew Swan [:aswan] from comment #4)

> Looks good, thanks!  Do you have access to try?
No I do not have access to try.

Could you please run it on try for me? Thanks!
Flags: needinfo?(aswan)
Pushed by aswan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6bdeea20331f
Fix location where Addon's "Preferences" tab is opened; r=aswan
Looks like your try run was clean:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=cb5acf5155e9e52f1971395721e076c2a084b1e6

I've gone ahead and landed the patch for you, thanks for the contribution!
Flags: needinfo?(aswan)
https://hg.mozilla.org/mozilla-central/rev/6bdeea20331f
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Thanks so much, Arjun! Your contribution has been added to the add-ons recognition wiki: https://wiki.mozilla.org/Add-ons/Contribute/Recognition#March_2018

Hope to keep seeing you around this part of the project! :)
Tested and reproduced issue in Firefox 60.0a1 (20180308100121) on Windows 10 64b.
Retested and verified in Firefox 61.0a1 (20180330100123) on Windows 10 64bit and MacOS 10.13.3.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.