Firefox logo is painted on top of "X" button when opening new tab

VERIFIED FIXED in Firefox 60

Status

()

defect
P1
normal
VERIFIED FIXED
a year ago
a year ago

People

(Reporter: edmorales.97, Assigned: dao)

Tracking

({regression})

59 Branch
Firefox 61
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox59 wontfix, firefox60 verified, firefox61 verified)

Details

Attachments

(3 attachments)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20180307211018

Steps to reproduce:

Open a new tab


Actual results:

The Firefox logo appears from the x...


Expected results:

It seems odd that the Firefox logo appears from the X. It looks like a flaw. Image attached. 

Sorry, OCD.
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:59.0) Gecko/20100101 Firefox/59.0 (20180310025718)

I've tested this issue on the mentioned Fx build, the latest Firefox Release and Nightly builds but I'm unable to reproduce it. 

Could you let us know if you have any pref explicitly set in about:config ? 

Also can you try to update to the latest and report back if you still experience this issue ?
Component: Untriaged → Tabbed Browser
Flags: needinfo?(edmorales.97)
(Reporter)

Comment 2

a year ago
well, you have to be quick to see it but i've been able to reproduce it on my other computer.

Open several times and look very closely at the "X" to close the tab.

I do not have any pref in about:config.

I have updated to the latest build and still notice the issue.
Flags: needinfo?(edmorales.97)
I had to record a short video and to play it really slow to notice the issue. When open a new tab the Firefox logo is painted for brief moment on top of the "X" button to close the tab.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(jaws)
OS: Unspecified → Mac OS X
Summary: Design flaw when opening new tab → Firefox logo is painted on top of "X" button when opening new tab OS X
Stefan or Eduardo, can you use mozregression [1] to find when this started happening? Since you've marked it as affecting Firefox since v59 then I'm not worried that it is a recent regression, but finding out when it was introduced will be a huge help for us to fix it.

[1] http://mozilla.github.io/mozregression/
Flags: needinfo?(stefan.georgiev)
Flags: needinfo?(jaws)
Flags: needinfo?(edmorales.97)
(Reporter)

Comment 5

a year ago
I ran it.

Below are the results.


16:01.10 INFO: Narrowed inbound regression window from [e2da49c6, 179f6c26] (3 builds) to [a1b4be31, 179f6c26] (2 builds) (~1 steps left)
16:01.10 INFO: No more inbound revisions, bisection finished.
16:01.10 INFO: Last good revision: a1b4be31e7a60a5312a801dff6b674244ee5703a
16:01.10 INFO: First bad revision: 179f6c267f84d0bdbab2233db5afc8909af5606a
16:01.10 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=a1b4be31e7a60a5312a801dff6b674244ee5703a&tochange=179f6c267f84d0bdbab2233db5afc8909af5606a
Flags: needinfo?(edmorales.97)
Blocks: 1401955
Flags: needinfo?(stefan.georgiev) → needinfo?(jhofmann)
I saw this on Windows 10 yesterday.
OS: Mac OS X → All
Hardware: Unspecified → All
Yeah, it would be good to fix this, but I'd say it's definitely not as bad as the previous flicker/loading.
Flags: needinfo?(jhofmann)
(Assignee)

Updated

a year ago
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Priority: -- → P1
Summary: Firefox logo is painted on top of "X" button when opening new tab OS X → Firefox logo is painted on top of "X" button when opening new tab
(Assignee)

Updated

a year ago
Depends on: 1453954
Comment hidden (mozreview-request)

Comment 10

a year ago
mozreview-review
Comment on attachment 8967730 [details]
Bug 1444288 - Hide the favicon at the beginning of the tab opening animation.

https://reviewboard.mozilla.org/r/236444/#review242636

That seems to work great, thank you.
Attachment #8967730 - Flags: review?(jhofmann) → review+
We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again.

hg error in cmd: hg rebase -s 631bfc106517b1e31861d1e82967499385f24b0e -d f902138acc12: rebasing 458544:631bfc106517 "Bug 1444288 - Hide the favicon at the beginning of the tab opening animation. r=johannh" (tip)
merging browser/base/content/browser.css
warning: conflicts while merging browser/base/content/browser.css! (edit, then use 'hg resolve --mark')
unresolved conflicts (see hg resolve, then hg rebase --continue)

Comment 12

a year ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9bab179fb575
Hide the favicon at the beginning of the tab opening animation. r=johannh
https://hg.mozilla.org/mozilla-central/rev/9bab179fb575
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
(Assignee)

Comment 14

a year ago
Approval Request Comment
[Feature/Bug causing the regression]: bug 1401955
[User impact if declined]: see comment 0
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]: probably a good idea; steps in comment 0
[List of other uplifts needed for the feature/fix]: /
[Is the change risky?]: no
[Why is the change risky/not risky?]: straightforward CSS-only fix
[String changes made/needed]: /
Attachment #8968459 - Flags: approval-mozilla-beta?
(Assignee)

Updated

a year ago
Flags: qe-verify+
Comment on attachment 8968459 [details] [diff] [review]
patch for uplift

css fix for the tab bar, approved for 60.0b14
Attachment #8968459 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
I was able to reproduce this issue using Nightly build (03-08-2018) and Beta 60.0b10 on Windows 10 and OS X 10.13. 

This issue is not reproducible anymore using the latest Nightly (4-20-2018) and Beta 60.0b14 builds on Windows 10 x64, OS X 10.13 and Ubuntu 16.04.

The Fx logo is not painted anymore on top of the "X" button when running the new tab opening animation.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.