Error initializing preference category paneGeneral: TypeError: document.getElementById(...) is null due to typo

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
a year ago
5 months ago

People

(Reporter: euthanasia_waltz, Assigned: gandalf)

Tracking

60 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox60 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Version  60.0b2
Build ID  20180307142707

STR:
1. Go to about:config and set identity.fxaccounts.enabled to false
2. Go to about:preferences

Browser Console:
 >Error initializing preference category paneGeneral: TypeError: document.getElementById(...) is null  preferences.js:158
 >TypeError: document.getElementById(...) is null  main.js:471:9

Cause:
https://hg.mozilla.org/mozilla-central/diff/9b1228043619/browser/components/preferences/in-content/main.xul#l1.30


BTW, resolving this issue with correcting typo will reveal another problem. 'Firefox Developer Edition Updates' section doesn't work. 'Check for updates' button causes error
 >TypeError: gAppUpdater is undefined  preferences:1:1
It is because of bug 1434706.
https://hg.mozilla.org/mozilla-central/diff/109cd0a34ffe/browser/components/preferences/in-content/main.js#l1.14
(Reporter)

Updated

a year ago
Blocks: 1435912
(Assignee)

Comment 1

a year ago
Thanks for reporting!
Assignee: nobody → gandalf
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Comment hidden (mozreview-request)
(Assignee)

Comment 3

a year ago
mozreview-review
Comment on attachment 8957751 [details]
Bug 1444564 - Fix a typo in Preferences main.xul.

https://reviewboard.mozilla.org/r/226718/#review232518
Attachment #8957751 - Flags: review+
(Assignee)

Updated

a year ago
Keywords: leave-open

Comment 4

a year ago
Pushed by zbraniecki@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d9c906ec2b7d
Fix a typo in Preferences main.xul. r=gandalf
(Assignee)

Comment 6

a year ago
Jared - I fixed the typo (sorry for that!), but I'm not sure where the other bug comes from. Can you assign it to the right person?
Flags: needinfo?(jaws)
Closing this bug as the two issues are independent. I'll file a new bug for the second issue.
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(jaws)
Resolution: --- → FIXED
Filed bug 1445028.
Summary: about:preferences#general is broken if identity.fxaccounts.enabled=false on Firefox Developer Edition → Error initializing preference category paneGeneral: TypeError: document.getElementById(...) is null due to typo

Updated

5 months ago
Depends on: 1511340
You need to log in before you can comment on or make changes to this bug.