Closed Bug 1444584 Opened 2 years ago Closed 2 years ago

Seamonkey 2.49.2 Linux x86_64 (Fedora 26) memory leak, computer eventually runs short of RAM and becomes flakey.

Categories

(SeaMonkey :: OS Integration, defect)

SeaMonkey 2.49 Branch
defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: cmoulton, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.2
Build ID: 20180218124456

Steps to reproduce:

I run system monitor and observe the steady climb in memory usage by seamonkey over several hours of use  


Actual results:

After Seamonkey memory reaches 6.5 GiB or so of the 8 GiB available the computer becomes unreliable, the mouse pointer movement becomes intermittent window switching becomes very slow for all windows not just the ones belonging to Seamonkey amd sometimes if the computer goes to sleep many presses (hundreds) of the space bar are required to wake it up and sometimes it will not wake and I have to hit the RESET switch.

Assuming the computer does not get completely nonfunctional I can use system monitor to kill the seamonkey process. When Seamonkey restarts with all windows recovered except for the mail window memory usage is comfortably less than 1GiB and the computer is no longer unreliable.

I have had this problem for a long time before I twigged that Seamonkey was involved. and put it down to senility of ageing hardware  Currently I am using seamonkey 2,49.2 but It may have occurred with previous update levels.

There is a Mozillazine thread started on 2017-07-25  July 2017 which is clearly the same problem and it explicitly refers to versions 2.40 & 2.46 and affects users of Windows OSes.

http://forums.mozillazine.org/viewtopic.php?f=5&t=3032024

Another possible feature of the problem is high CPU usage by Seamonkey even when it is not in use, around 25% There is some suspicion by posters on that thread that opening of an excessive number of Windows or Tabs may be a contributor at this instant I have 25 tabs open over 4 windows.




Expected results:

Seamonkey should be able to run for days at a time as I normally leave the PC running until some problem forces a reboot.
Nothing in the bug which we can work with to fix it. See thread.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
What extra information can I collect and submit to help resolution?

One thing, the bug appears to be related to having a lage number of tabs/window open. I normally run Seamonkey with more than 12 tabs open but lately as a test have been restricting my use to four tabs and the memory leak does not manifest or if it is manifesting is extremely slow.
You need to log in before you can comment on or make changes to this bug.