Mac: Mouse pointer disappears when using keyboard navigation.

RESOLVED INVALID

Status

()

Core
XUL
RESOLVED INVALID
16 years ago
11 years ago

People

(Reporter: michael wendell, Assigned: jag (Peter Annema))

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
When using keyboard navigation on a Mac, the mouse pointer disappears.

Steps to reproduce:
1. Load any webpage, and position the cursor within the browser window
2. Hit the tab key 

Actual results:
Mouse pointer disappers until you move the mouse.

Expected results:
I would expect that the pointer would remain visible.

I am sure someone else has reported this, but I could not find it.

I am able to reproduce this problem on the following builds:
Mac OS9.2 05-12 xxPR1 and 05-13 trunk builds
Mac OSX 05-13 trunk, 05-12 xxPR1, and 05-10 1.0.0 branch builds.
-> XP Toolkit
Assignee: Matti → jaggernaut
Component: Browser-General → XP Toolkit/Widgets
QA Contact: imajes-qa → jrgm

Comment 2

15 years ago
This bug is targeted at a Mac classic platform/OS, which is no longer supported
by mozilla.org. Please re-target it to another platform/OS if this bug applies
there as well or resolve this bug.

I will resolve this bug as WONTFIX in four weeks if no action has been taken.
To filter this and similar messages out, please filter for "mac_cla_reorg".

Updated

15 years ago
OS: Mac System 9.x → MacOS X

Comment 3

15 years ago
This is not a bug, it's standard behaviour on the Mac to hide the mouse pointer
while typing.

I see the same behaviour in Safari 1.0, Internet Explorer 5.2, Hydra, TextEdit,
... Even in Network Utility.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5b) Gecko/20030910
Mac OS X 10.2.6

Comment 4

12 years ago
I believe this is expected behavior (see also comment 3).  Resolving this as invalid.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
*** Bug 364804 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.