Closed Bug 1444845 Opened 2 years ago Closed 2 years ago

Surplus scrolling when stop autoscroll with mouse wheel

Categories

(Firefox :: Tabbed Browser, defect, P5)

60 Branch
Unspecified
Windows 10
defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox-esr52 --- unaffected
firefox58 --- unaffected
firefox59 --- unaffected
firefox60 --- wontfix
firefox61 --- wontfix
firefox62 --- fixed
firefox63 --- fixed

People

(Reporter: alice0775, Unassigned)

References

Details

(Keywords: regression)

[Tracking Requested - why for this release]: ux regression


Reproduce: always

Steps To Reproduce:
1. Open any long page such as http://archive.mozilla.org/pub/firefox/nightly/2017/12/
2. Middle click on empty area so that perform autoscroll
3. Turn mouse wheel to stop autoscroll

Actual Results:
Surplus scrolling occurs

Expected Results:
No such surplus scrolling. Just stop autoscroll


Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=4bd1219880f9c3bcbc6136160003d6fbb51655cd&tochange=562966f195b0f071cf1d973f7b4fd51ec8594343

Regressed by:
562966f195b0	Dão Gottwald — Bug 1442651 - Remove the tabbrowser element and binding. r=bgrins
Hey Dao, can we get a priority on this for triage please. Thanks!
Flags: needinfo?(dao+bmo)
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(dao+bmo)
Resolution: --- → DUPLICATE
Duplicate of bug: 1443937
unfortunately, bug 1443937 did not fix the problem completely.


The surplus scrolling will still occur when the mouse wheel is rotated over the autoscroll marker.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Priority: -- → P5
"wontfix" is enough
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → WONTFIX
Fixed by Bug 1467867 if WebRender is disabled.
fixed range: https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=3a3bbb2e68ef7429368c347c53b4ac819b5db6a0&tochange=192713c16fc1f199c78f470f11c3c6f12109ec27

However, If WebRender is enabled, the problem is still reproduced. (filed Bug 1477995)
Depends on: 1467867
Resolution: WONTFIX → FIXED
You need to log in before you can comment on or make changes to this bug.