Closed Bug 1444855 Opened 3 years ago Closed 2 months ago

New Feature: Edit Textarea with External Editor

Categories

(Core :: Layout: Form Controls, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 13474

People

(Reporter: svoop, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20180206200532

Steps to reproduce:

The ability to edit textarea content with an external editor is one of the longest running feature requests (almost two decades), see bugs #13474 and #103767.

Add-ons like "It's All Text" added this functionality until FF56, however, the new extensions architecture apparently no longer permits extensions to communicate with an external editor directly via the filesystem. 

Some new extensions like "ghosttext" or "external-editor" try to work around this limitation by spawning a server which acts as the glue between FF and the external editor. Unfortunately, none of these solutions is satisfactory since this cumbersome setup is much more error prone which results in unacceptable data loss.

With the rise of documentation wikis (GitHub) or online editors in recent years, the need to edit textarea content in external editors has been steadily growing – specially for developers. Proper built-in support would be a killer feature, thanks for giving it some thought!


Specially developers need a way to edit large textarea content in external editors (e.g. documentation wiki à la GitHub) to be productive and prevent frequent copy-pasting.

Thank you so much for giving this really long-running feature request (nearly two decades!) a thought, proper support for textarea external editors would be a killer feature for many people, most certainly developers!
How is this not a duplicate of bug 13474?
Severity: normal → enhancement
Has Regression Range: --- → irrelevant
Has STR: --- → irrelevant
Component: Untriaged → Layout: Form Controls
Flags: needinfo?(svoop)
OS: Unspecified → All
Product: Firefox → Core
Hardware: Unspecified → All
It is, which is why I mention it and another duplicate. Both of which are almost two decades old. And both are assigned to "nobody", which is why commenting there will not even trigger a notification anywhere. Hence this new feature request.
Flags: needinfo?(svoop)

Still a dupe (and duping a bug fires notifications). I agree this would be a nice feature, and it might not even be hard to do from the context menu code these days.

Status: UNCONFIRMED → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 13474
You need to log in before you can comment on or make changes to this bug.