installer will not proceed past the running instances check

VERIFIED WORKSFORME

Status

SeaMonkey
Installer
VERIFIED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Frank Goss, Assigned: Curt Patrick (gone))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.4) Gecko/20011019
Netscape6/6.2
BuildID:    1.0 RC2

running the installer on HP Kayak with Windows NT 4.0 sp6. it starts the install
and displays a dialog box asking me to close opened Mozilla windows except I
don't have any open Mozilla windows. I have re-booted my PC (power down) and
still get stuck at the same place. I have previously installed version 1.0 RC1
which was working. It now does not work.

Reproducible: Always
Steps to Reproduce:
1.run the installer
2.
3.

Actual Results:  gets stuck asking me to close opened Mozilla windows

Expected Results:  continue the install process
Reporter, when you get in this state, please bring up the NT task manager and
look at the running processes. Is there a mozilla.exe running in the background?
We're supposed to shut that down, but if that's not happening you can do it
manually (kill it if you have to as a last resort) to get beyond this problem.

over to curt, but I'd like someone to confirm this sighting or get more details
because QA did test this scenario.

Assignee: dveditz → curt
Adding Sean in case he can think of a case where this might happen.
Summary: installer does not complete → installer will not proceed past the running instances check

Comment 3

16 years ago
My guess would be that the reporter has turn on quick launch (turbo) in a
previous mozilla build, and closed all the visible windows.

The 6.2 installer will detect the quick launch laying silently in the task bar.
 Even after a system reboot, mozilla will probably launch itself in quicklaunch
mode, thus you still get the error message after a reboot.

But this is just a guess given the info in this bug. We'll have to wait on a
response from the reporter about what shows up in his task manager.
Yes, I also suspect quick launch, but I see code that looks like an explicit
attempt to shut it down and I know I remember QA testing that scenario.

Comment 5

16 years ago
reporter: are you trying to install Netscape 6 or Mozilla?

it's impossible to install Netscape 6 with Mozilla running!
Henrik: are you speaking from past experience, or have you tried it recently?
Code has been changed, and last time I checked (this morning, prompted by this
bug) I could install one while the other was running. Of course I have access to
newer versions of Netscape than most people :-)

Comment 7

16 years ago
Dan: I tried to install Netscap 6.2.3 when Mozilla was running. Failed. Not sure
about Netscape 7...

Comment 8

16 years ago
I did some testing using both ns 6.2.3 and ns machv along with Mozilla rc2

Mozilla does not ask users to close down NS versions nor does Machv ask to close 
down Mozilla (with or without QL on)
Mozilla does detect any instances of mozilla - the app or Ql and do the right 
thing as does MachV

NS 6.2.3 (as noted by Henrik) does detect Mozilla (and MachV) running and does 
not remove the  moz QL icon as MachV does 

It appears that with current versions, you can install MachV or Mozilla while 
the other is running. 

will attach test results

Comment 9

16 years ago
Created attachment 83731 [details]
test results
(Reporter)

Comment 10

16 years ago
I deleted the Quick Launch from the taskbar and found a mozilla.exe running when
I brought up the Task Manager.This elminated the dialog box telling me to quit a
running copy of Mozilla. I was able to update my version of Netscape from 6.2 to
6.2.3 with no trouble. 

I still had a problem updating Mozilla from 1.0 RC1 to 1.0 RC2. I uninstalled
Mozilla 1.0 RC1 and was then able to install 1.0 RC2. The file I used was
mozilla-win32-1.0rc2-installer.exe.

Updated

16 years ago
Severity: blocker → normal
Please reopen if you had the same problem upgrading from rc2 to rc3 or 1.0 final
and we'll dig deeper. Otherwise we're just not seeing it here, sorry.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 12

16 years ago
vfd
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → gbush
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.