Targeted unread count badge border radius does not apply

RESOLVED FIXED in Thunderbird 66.0

Status

defect
RESOLVED FIXED
a year ago
4 months ago

People

(Reporter: freaktechnik, Assigned: Paenglab)

Tracking

unspecified
Thunderbird 66.0
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird65 fixed, thunderbird66 fixed)

Details

Attachments

(3 attachments)

Posted image badge-edges.png
The badge on the chat button that shows the count of unread mentions/targeted messages does not get its borders rounded properly when a value is set.

A possible fix is to wrap the label in a box and style the box instead.
Reporter

Updated

a year ago
OS: Unspecified → All
Hardware: Unspecified → All

I think I'm seeing the same behavior on current beta, but I'm not 100% sure how it is SUPPOSED to look.

Maybe Richard has an idea if there is anything actionable here?

Flags: needinfo?(richard.marti)
Assignee

Comment 2

4 months ago

It seems on the label itself border-radius works no more. Wrapping the label inside a box and apply the styles to the box fixes this.

Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Flags: needinfo?(richard.marti)
Attachment #9036516 - Flags: review?(clokep)
Posted image comparison.png

Comparison of with and without the patch.

Comment on attachment 9036516 [details] [diff] [review]
1444987-badge-radius.patch

Review of attachment 9036516 [details] [diff] [review]:
-----------------------------------------------------------------

So I wasn't really sure whether to approve this or not -- I think we could do a much better job with this icon. I'm giving it an r+ because it fixes the actual issue and I think we should uplift this to beta sooner rather than later.
Attachment #9036516 - Flags: review?(clokep) → review+
Comment on attachment 9036516 [details] [diff] [review]
1444987-badge-radius.patch

[Approval Request Comment]
Regression caused by (bug #): See attachment 9037416 [details]
User impact if declined: Broken styling on icon
Testing completed (on c-c, etc.): None
Risk to taking this patch (and alternatives if risky): Small risk, if anything the styling will just be broken in a different way
Attachment #9036516 - Flags: approval-comm-beta?
Assignee

Updated

4 months ago
Keywords: checkin-needed

Comment 6

4 months ago

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/151bb059674b
Make the border-radius on the badges working again. r=clokep

Status: ASSIGNED → RESOLVED
Last Resolved: 4 months ago
Keywords: checkin-needed
Resolution: --- → FIXED

Updated

4 months ago
Target Milestone: --- → Thunderbird 66.0

Updated

4 months ago
Attachment #9036516 - Flags: approval-comm-beta? → approval-comm-beta+

We should probably wait on uplifting this since we suspect it is causing bug 1521481.

Depends on: 1521481
You need to log in before you can comment on or make changes to this bug.