Closed Bug 1445131 Opened 2 years ago Closed 2 years ago

Double-clicking at the top of the content area minimizes the browser window (macOS)

Categories

(Core :: Widget: Cocoa, defect, P1)

All
macOS
defect

Tracking

()

VERIFIED FIXED
mozilla61
Tracking Status
firefox-esr52 --- unaffected
firefox59 --- unaffected
firefox60 + verified
firefox61 --- verified

People

(Reporter: MattN, Assigned: mstange)

References

Details

(Keywords: regression, reproducible)

Attachments

(3 files)

Double-clicking in the top 10-20 pixels of content area minimizes the whole window on macOS in a new profile. I encountered this while double-clicking in a text field to select all text near the top of a page. I'm not sure what the exact conditions to reproduce are… it seems like some areas don't exhibit the problem e.g. in the BMO search box.

STR:
1) Load any page (AFAICT)
2) Double-click near the top 10-20 pixels in a blank area.

Last good revision: 93b6538bc167b53884d1a8590f0e2f67f124c358
First bad revision: 5e9db9c66ccdbe20d8ebb8c498a4385c4dc54ea0
Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=93b6538bc167b53884d1a8590f0e2f67f124c358&tochange=5e9db9c66ccdbe20d8ebb8c498a4385c4dc54ea0

which only contains bug 1401195 which is definitely relevant.

[Tracking Requested - why for this release]: New regression
Flags: needinfo?(mstange)
Flags: in-testsuite?
Has Regression Range: --- → yes
Has STR: --- → yes
Duplicate of this bug: 1444802
I can't reproduce this on my Mac :/
Ok, a little more precision: this only occurs under the area that's on the tabbar but currently empty. When the "normal" titlebar is disabled, that's between the tricolour state buttons and the first tab, and in all cases it's also between the add tab (+ icon) (or last tab) and the end of the tab row. The zone is also wider than reported, about 50px (maybe less physical space on Retina?).
In case my description was confusing, I made a diagram showing (in light blue) the zones where I've observed this occurring. It happens on any page, whether the area under the mouse is blank, headings, text, inputs, etc. Where it occurs depends entirely on where the "free space" on the tabbar is.
Attached video double_click_issue.mov
I can reproduce it on macOS 10.12.6 with latest Nightly.

Attached a screencast.
Assignee: nobody → mstange
Status: NEW → ASSIGNED
Flags: needinfo?(mstange)
Duplicate of this bug: 1445902
tracking as new regression in 60
Comment on attachment 8958979 [details]
Bug 1445131 - When testing the event's position against the window's draggable region, read the position when it's still in the correct coordinate space.

https://reviewboard.mozilla.org/r/227840/#review233904
Attachment #8958979 - Flags: review?(spohl.mozilla.bugs) → review+
Pushed by mstange@themasta.com:
https://hg.mozilla.org/integration/autoland/rev/9d0154e7d12b
When testing the event's position against the window's draggable region, read the position when it's still in the correct coordinate space. r=spohl
Priority: -- → P1
https://hg.mozilla.org/mozilla-central/rev/9d0154e7d12b
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Please request Beta approval on this when you're comfortable doing so.
Flags: needinfo?(mstange)
Comment on attachment 8958979 [details]
Bug 1445131 - When testing the event's position against the window's draggable region, read the position when it's still in the correct coordinate space.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1401195
[User impact if declined]: unintentional window dragging
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: n/a
[Is the change risky?]: no
[Why is the change risky/not risky?]: very simple fix, in code that's exercised all the time, no problems on nightly
[String changes made/needed]: none
Flags: needinfo?(mstange)
Attachment #8958979 - Flags: approval-mozilla-beta?
Comment on attachment 8958979 [details]
Bug 1445131 - When testing the event's position against the window's draggable region, read the position when it's still in the correct coordinate space.

mac regression fix for beta60
Attachment #8958979 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [good first verify]
I successfully reproduced the issue on Firefox Nightly (2018-03-12) under macOS 10.12 following STR from Comment 0.

The issue is no longer reproducible on latest Nightly (2018-04-01) and Firefox 60.0b8 under macOS 10.12, Ubuntu 16.04 (x64) and Windows 10 (x64)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.