Closed Bug 1445140 Opened 2 years ago Closed 2 years ago

Remove nsIDOMDocumentType

Categories

(Core :: DOM: Core & HTML, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla61
Tracking Status
firefox61 --- fixed

People

(Reporter: bzbarsky, Assigned: bzbarsky)

References

Details

Attachments

(5 files)

No description provided.
MozReview-Commit-ID: 6sEFIfMgqet
Attachment #8958542 - Flags: review?(continuation)
MozReview-Commit-ID: EGA6OOSbnWV
Attachment #8958543 - Flags: review?(continuation)
MozReview-Commit-ID: 5UjRSP6MoDI
Attachment #8958544 - Flags: review?(continuation)
MozReview-Commit-ID: D9Xwt3qJQDI
Attachment #8958545 - Flags: review?(continuation)
MozReview-Commit-ID: B6iktNYbWn9
Attachment #8958546 - Flags: review?(continuation)
Attachment #8958542 - Flags: review?(continuation) → review+
Attachment #8958543 - Flags: review?(continuation) → review+
Attachment #8958544 - Flags: review?(continuation) → review+
Comment on attachment 8958545 [details] [diff] [review]
part 4.  Remove nsIDOMDocumentType members

Review of attachment 8958545 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/base/DocumentType.cpp
@@ -102,4 @@
>  {
>    aSystemId = mSystemId;
> -
> -  return NS_OK;

I wonder how much CPU time Firefox has collectively burned over time from returning NS_OK values from methods that never fail.
Attachment #8958545 - Flags: review?(continuation) → review+
I wonder too, but probably less than from doing the virtual calls involved....
Attachment #8958546 - Flags: review?(continuation) → review+
Pushed by bzbarsky@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/dbd6871846be
part 1.  Remove the XPCOM-ish version of NS_NewDOMDocumentType.  r=mystor
https://hg.mozilla.org/integration/mozilla-inbound/rev/b5a6b2e65e39
part 2.  Change NS_NewDOMDocument to take a DocumentType.  r=mystor
https://hg.mozilla.org/integration/mozilla-inbound/rev/acf0aa76d956
part 3.  Pass a DocumentType to nsIContentSerializer::AppendDoctype.  r=mystor
https://hg.mozilla.org/integration/mozilla-inbound/rev/8591715576b9
part 4.  Remove nsIDOMDocumentType members.  r=mystor
https://hg.mozilla.org/integration/mozilla-inbound/rev/09cca071ae89
part 5.  Remove nsIDOMDocumentType.  r=mystor
Duplicate of this bug: 840401
You need to log in before you can comment on or make changes to this bug.