Page layout rendered improperly

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
17 years ago
16 years ago

People

(Reporter: mbahabib, Assigned: karnaze)

Tracking

({qawanted, testcase})

Trunk
mozilla1.1beta
x86
All
qawanted, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testcase], URL)

Attachments

(6 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc1)
Gecko/20020417
BuildID:    2002041711

When rendering this page Mozilla misaligns items on page such as paragraphs and
images.

Reproducible: Always
Steps to Reproduce:
1. Load page :
http://www.zdnet.com.au/itmanager/technology/story/0,2000029587,20265210,00.htm
2.
3.

Actual Results:  Paragraphs and images are misaligned.

Expected Results:  Paragraphs and images should be aligned properly.

GrayModern Theme was used.
Which part is misaligned exactly?  Could you attach a screenshot using
http://bugzilla.mozilla.org/attachment.cgi?bugid=144527&action=enter ?
(Reporter)

Comment 2

17 years ago
Created attachment 83710 [details]
Attachment showing misalignment on page are circled in red

*** This bug has been marked as a duplicate of 128597 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

17 years ago
How is Bug # 128597 a duplicate of this bug? I also noticed that Bug # 140522 & 
99280 were also assigned duplicates of Bug # 128597. There is more similarities 
between this bug and Bug # 140522 & 99280 then there is between this bug and 
Bug # 128597. Please explain Boris. Thanks
(Reporter)

Comment 5

17 years ago
Created attachment 83718 [details]
Select View | Text Zoom | 100 % while text still misaligned

On a different note, I did notice that if I selected View | Text Zoom | 100 %
again after the page had already loaded incorrectly misaligned, even though by
default 100% is selected, the alignment problem is solved.
(Reporter)

Comment 6

17 years ago
Created attachment 83719 [details]
Snapshot of alignment corrected after selecting View | Text Zoom | 100 %

This indicates to me that some method is called when View | Text Zoom | 100 %
is select that is not called during page load that causes the misalignment.
If rezooming fixes it, it's a real problem.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
This is tables.
Assignee: attinasi → karnaze
Status: UNCONFIRMED → NEW
Component: Layout → HTMLTables
Ever confirmed: true
QA Contact: petersen → amar

Comment 9

17 years ago
a  minimized testcase is more helpful than screen shots:
http://www.mozilla.org/newlayout/bugathon.html
(Reporter)

Comment 10

17 years ago
Test Case:

1. Load the following page below:
http://www.zdnet.com.au/itmanager/technology/story/0,2000029587,20265210,00.htm

2. Misalignment problems should now be visible as shown in the 1st attachement 
linked below:
http://bugzilla.mozilla.org/attachment.cgi?id=83710&action=view

3. From Mozilla's Menu Bar select View | Text Zoom | 100 % as shown in the 2nd 
attachment linked below:
http://bugzilla.mozilla.org/attachment.cgi?id=83718&action=view

4. Misalignment problems should now be fixed as shown in the 3rd attachment 
linked below:
http://bugzilla.mozilla.org/attachment.cgi?id=83719&action=view

Comment 11

17 years ago
*** Bug 144800 has been marked as a duplicate of this bug. ***

Comment 12

17 years ago
A minimized test case would be helpful here.
Keywords: qawanted
Whiteboard: [testcase]
(Reporter)

Comment 13

17 years ago
Chris & Bernd, I'm currently working on minimized test case.
(Reporter)

Comment 14

17 years ago
Created attachment 83771 [details]
Minimized test case

My first minimized test case so I might have missed some things.

Comment 15

17 years ago
144800, marked as duplicate of this bug, is under linux - suggest OS->All ?
This exists in 4.77 under linux too.
(Reporter)

Updated

17 years ago
OS: Windows 2000 → All

Comment 16

17 years ago
Created attachment 83965 [details]
ZDnet as seen in Microsoft Internet Explorer, version 6

Comment 17

17 years ago
Created attachment 84144 [details]
reduced testcase

Comment 18

17 years ago
Adding testcase keyword.
Keywords: testcase

Updated

16 years ago
Priority: -- → P3
(Assignee)

Comment 19

16 years ago
In the "reduced testcase", it looks like the body block is returning a smaller 
desired width than the table.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.1beta
WFM, 2002-07-27-21 (trunk) on Linux.
-> WORKSFORME
      2002-08-17-05 trunk Linux.
      2002-08-18-08 trunk Windows 2000.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.