Closed Bug 1445413 Opened 2 years ago Closed 2 years ago

Intermittent make[4]: *** [Unified_cpp_netwerk_cookie0.o] Error 101

Categories

(Core :: Widget: Gtk, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1445631

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

(Keywords: intermittent-failure)

Filed by: ncsoregi [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=167739365&repo=autoland

https://queue.taskcluster.net/v1/task/e9JzihVJRMCVxBLyb_tvVQ/runs/0/artifacts/public/logs/live_backing.log

[task 2018-03-13T18:32:46.206Z] 18:32:46     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/netwerk/protocol/websocket'
[task 2018-03-13T18:32:46.206Z] 18:32:46     INFO -  mkdir -p '.deps/'
[task 2018-03-13T18:32:46.206Z] 18:32:46     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/netwerk/protocol/websocket'
[task 2018-03-13T18:32:46.206Z] 18:32:46     INFO -  make[4]: *** Deleting file 'Unified_cpp_netwerk_cookie0.o'
[task 2018-03-13T18:32:46.207Z] 18:32:46     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/netwerk/cookie'
[task 2018-03-13T18:32:46.214Z] 18:32:46     INFO -  /builds/worker/workspace/build/src/sccache2/sccache /builds/worker/workspace/build/src/clang/bin/clang++ -std=gnu++14 -o Unified_cpp_netwerk_cookie0.o -c -I/builds/worker/workspace/build/src/obj-firefox/dist/stl_wrappers -I/builds/worker/workspace/build/src/obj-firefox/dist/system_wrappers -include /builds/worker/workspace/build/src/config/gcc_hidden.h -DDEBUG=1 -DOS_POSIX=1 -DOS_LINUX=1 -DSTATIC_EXPORTABLE_JS_API -DMOZ_HAS_MOZGLUE -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -I/builds/worker/workspace/build/src/netwerk/cookie -I/builds/worker/workspace/build/src/obj-firefox/netwerk/cookie -I/builds/worker/workspace/build/src/intl/uconv -I/builds/worker/workspace/build/src/obj-firefox/ipc/ipdl/_ipdlheaders -I/builds/worker/workspace/build/src/ipc/chromium/src -I/builds/worker/workspace/build/src/ipc/glue -I/builds/worker/workspace/build/src/obj-firefox/dist/include -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nspr -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nss -fPIC -DMOZILLA_CLIENT -include /builds/worker/workspace/build/src/obj-firefox/mozilla-config.h -Qunused-arguments -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -Qunused-arguments -Wall -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wsign-compare -Wtype-limits -Wunreachable-code -Wunreachable-code-return -Wwrite-strings -Wno-invalid-offsetof -Wclass-varargs -Wloop-analysis -Wc++1z-compat -Wcomma -Wimplicit-fallthrough -Werror=non-literal-null-conversion -Wstring-conversion -Wno-inline-new-delete -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wformat -Wformat-security -Wno-gnu-zero-variadic-macro-arguments -Wno-unknown-warning-option -Wno-return-type-c-linkage -D_GLIBCXX_USE_CXX11_ABI=0 -fno-sized-deallocation -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -pthread -pipe -g -Xclang -load -Xclang /builds/worker/workspace/build/src/obj-firefox/build/clang-plugin/libclang-plugin.so -Xclang -add-plugin -Xclang moz-check -Os -fno-omit-frame-pointer -Werror -Wno-error=shadow  -MD -MP -MF .deps/Unified_cpp_netwerk_cookie0.o.pp   /builds/worker/workspace/build/src/obj-firefox/netwerk/cookie/Unified_cpp_netwerk_cookie0.cpp
[task 2018-03-13T18:32:46.214Z] 18:32:46     INFO -  thread 'main' panicked at 'failed to shut down worker thread', /builds/worker/.cargo/registry/src/github.com-1ecc6299db9ec823/jobserver-0.1.9/src/lib.rs:650:17
[task 2018-03-13T18:32:46.214Z] 18:32:46     INFO -  note: Run with `RUST_BACKTRACE=1` for a backtrace.
[task 2018-03-13T18:32:46.214Z] 18:32:46     INFO -  /builds/worker/workspace/build/src/config/rules.mk:1045: recipe for target 'Unified_cpp_netwerk_cookie0.o' failed
[task 2018-03-13T18:32:46.215Z] 18:32:46     INFO -  make[4]: *** [Unified_cpp_netwerk_cookie0.o] Error 101
[task 2018-03-13T18:32:46.216Z] 18:32:46     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/netwerk/cookie'
[task 2018-03-13T18:32:46.216Z] 18:32:46     INFO -  /builds/worker/workspace/build/src/config/recurse.mk:73: recipe for target 'netwerk/cookie/target' failed
[task 2018-03-13T18:32:46.217Z] 18:32:46     INFO -  make[3]: *** [netwerk/cookie/target] Error 2
[task 2018-03-13T18:32:46.218Z] 18:32:46     INFO -  make[3]: *** Waiting for unfinished jobs....
[task 2018-03-13T18:32:46.222Z] 18:32:46     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/netwerk/protocol/http'
[task 2018-03-13T18:32:46.222Z] 18:32:46     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/netwerk/protocol/http'
[task 2018-03-13T18:32:46.258Z] 18:32:46     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/netwerk/protocol/websocket'
[task 2018-03-13T18:32:46.258Z] 18:32:46     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/netwerk/protocol/websocket'
[task 2018-03-13T18:32:46.556Z] 18:32:46     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/netwerk/protocol/gio'
[task 2018-03-13T18:32:46.561Z] 18:32:46     INFO -  /builds/worker/workspace/build/src/sccache2/sccache /builds/worker/workspace/build/src/clang/bin/clang++ -std=gnu++14 -o nsGIOProtocolHandler.o -c -I/builds/worker/workspace/build/src/obj-firefox/dist/stl_wrappers -I/builds/worker/workspace/build/src/obj-firefox/dist/system_wrappers -include /builds/worker/workspace/build/src/config/gcc_hidden.h -DDEBUG=1 -DSTATIC_EXPORTABLE_JS_API -DMOZ_HAS_MOZGLUE -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -I/builds/worker/workspace/build/src/netwerk/protocol/gio -I/builds/worker/workspace/build/src/obj-firefox/netwerk/protocol/gio -I/builds/worker/workspace/build/src/obj-firefox/dist/include -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nspr -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nss -fPIC -DMOZILLA_CLIENT -include /builds/worker/workspace/build/src/obj-firefox/mozilla-config.h -Qunused-arguments -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -Qunused-arguments -Wall -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wsign-compare -Wtype-limits -Wunreachable-code -Wunreachable-code-return -Wwrite-strings -Wno-invalid-offsetof -Wclass-varargs -Wloop-analysis -Wc++1z-compat -Wcomma -Wimplicit-fallthrough -Werror=non-literal-null-conversion -Wstring-conversion -Wno-inline-new-delete -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wformat -Wformat-security -Wno-gnu-zero-variadic-macro-arguments -Wno-unknown-warning-option -Wno-return-type-c-linkage -D_GLIBCXX_USE_CXX11_ABI=0 -fno-sized-deallocation -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -pthread -pipe -g -Xclang -load -Xclang /builds/worker/workspace/build/src/obj-firefox/build/clang-plugin/libclang-plugin.so -Xclang -add-plugin -Xclang moz-check -Os -fno-omit-frame-pointer -Werror -I/builds/worker/workspace/build/src/widget/gtk/compat-gtk3 -pthread -I/usr/include/gtk-3.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/libpng12 -I/usr/include/gtk-3.0/unix-print  -MD -MP -MF .deps/nsGIOProtocolHandler.o.pp   /builds/worker/workspace/build/src/netwerk/protocol/gio/nsGIOProtocolHandler.cpp
[task 2018-03-13T18:32:46.562Z] 18:32:46     INFO -  make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/netwerk/protocol/gio'
[task 2018-03-13T18:32:46.569Z] 18:32:46     INFO -  make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/netwerk/protocol/gio'
[task 2018-03-13T18:32:46.569Z] 18:32:46     INFO -  libnetwerk_protocol_gio.a.desc
(In reply to Treeherder Bug Filer from comment #0)
> [task 2018-03-13T18:32:46.214Z] 18:32:46     INFO - /builds/worker/workspace/build/src/sccache2/sccache /builds/worker/workspace/build/src/clang/bin/clang++
[...]
> [task 2018-03-13T18:32:46.214Z] 18:32:46     INFO -  thread 'main' panicked at 'failed to shut down worker thread', /builds/worker/.cargo/registry/src/github.com-1ecc6299db9ec823/jobserver-0.1.9/src/lib.rs:650:17
> [task 2018-03-13T18:32:46.214Z] 18:32:46     INFO -  note: Run with `RUST_BACKTRACE=1` for a backtrace.

This seems like the important part.
Thanks for the cc! I believe this is "fixed" (aka papered over) in https://github.com/alexcrichton/jobserver-rs/commit/283b9f77d531b26860b952ca353f04764e626dd3

I'm not actually sure how this could be caused but presumably something odd is going on and for now it's probably best to just ignore the error.

I've published 0.1.11, so a rebuilt sccache binary should hopefully not longer hit this.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1445631
You need to log in before you can comment on or make changes to this bug.