Blurry text in focused tab using Dark Theme

RESOLVED FIXED in Firefox 61

Status

()

defect
P3
normal
RESOLVED FIXED
Last year
23 days ago

People

(Reporter: marcia, Assigned: dao)

Tracking

(Regression, {regression})

Trunk
Firefox 61
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox59 wontfix, firefox60 wontfix, firefox61 fixed)

Details

Attachments

(4 attachments)

Noticed this shortly after my update to the beta: 20180312152746 60.0b3. Running 10.13.4 Beta (17E182a)

Any tab I place focus on is blurry. See attached screenshot.

Graphics
--------

Features
Compositing: OpenGL
Asynchronous Pan/Zoom: wheel input enabled; scrollbar drag enabled; keyboard enabled; autoscroll enabled
WebGL 1 Driver WSI Info: CGL
WebGL 1 Driver Renderer: Intel Inc. -- Intel(R) Iris(TM) Graphics 550
WebGL 1 Driver Version: 4.1 INTEL-10.32.45
WebGL 1 Driver Extensions: GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_attrib_64bit GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
WebGL 1 Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_sRGB EXT_shader_texture_lod EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context
WebGL 2 Driver WSI Info: CGL
WebGL 2 Driver Renderer: Intel Inc. -- Intel(R) Iris(TM) Graphics 550
WebGL 2 Driver Version: 4.1 INTEL-10.32.45
WebGL 2 Driver Extensions: GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_attrib_64bit GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
WebGL 2 Extensions: EXT_color_buffer_float EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_texture_float_linear WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_lose_context
Uses Tiling: true
Off Main Thread Painting Enabled: true
Off Main Thread Painting Worker Count: 1
GPU #1
Active: Yes
Vendor ID: 0x8086
Device ID: 0x1927

Diagnostics
AzureCanvasAccelerated: 1
AzureCanvasBackend: skia
AzureContentBackend: skia
AzureFallbackCanvasBackend: none
TileHeight: 512
TileWidth: 512
Decision Log
WEBRENDER:
opt-in by default: WebRender is an opt-in feature
unavailable by runtime: Build doesn't include WebRender
Looks like the tab itself is missing its light gray background. This sounds like a Theme bug.

The text looks blurry on the black background, but only because it's expecting to be drawn onto a light background.
Yes, I can confirm when switching back to the default theme the issue goes away. It appears a few of the dark themes I tried were problematic.
Component: Graphics → Theme
Product: Core → Firefox
Summary: Blurry text in focused tab → Blurry text in focused tab using Dark Theme
Can you find out which theme exactly it was? The toolbar itself is still light.

If it's an add-on theme, we should probably remove the -moz-font-smoothing-background-color rule here when such a theme is used: https://searchfox.org/mozilla-central/rev/8fa0b32c84f924c6809c690117dbd59591f79607/browser/themes/osx/browser.css#746-748
(In reply to Markus Stange [:mstange] from comment #3)
> Can you find out which theme exactly it was? The toolbar itself is still
> light.
> 
> If it's an add-on theme, we should probably remove the
> -moz-font-smoothing-background-color rule here when such a theme is used:
> https://searchfox.org/mozilla-central/rev/
> 8fa0b32c84f924c6809c690117dbd59591f79607/browser/themes/osx/browser.css#746-
> 748

The theme I see it with is the Black Wolf Theme: https://addons.mozilla.org/en-US/firefox/addon/the-black-wolf/

Another theme which has a different issue is https://addons.mozilla.org/en-US/firefox/addon/bluemotif/ - in that theme I can see the text in my focused tab but not the unfocused ones.
Both themes work fine for me in the current Beta build.
Blocks: 1387594
Priority: -- → P3
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Comment on attachment 8970497 [details]
Bug 1445671 - Stop using -moz-font-smoothing-background-color for the selected tab when using a lightweight theme.

https://reviewboard.mozilla.org/r/239266/#review245208
Attachment #8970497 - Flags: review?(mstange) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7b8e832071f1
Stop using -moz-font-smoothing-background-color for the selected tab when using a lightweight theme. r=mstange
https://hg.mozilla.org/mozilla-central/rev/7b8e832071f1
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
QA Whiteboard: [good first verify]
Depends on: 1562220
No longer blocks: 1387594
Keywords: regression
Regressed by: 1387594
You need to log in before you can comment on or make changes to this bug.