Closed Bug 1445672 Opened 2 years ago Closed 2 years ago

Download link points to Beta instead of Stable release

Categories

(Release Engineering :: Release Automation: Other, defect, P1, critical)

x86_64
Linux
defect

Tracking

(firefox-esr52 unaffected, firefox59 unaffected, firefox60blocking fixed, firefox61 fixed)

RESOLVED FIXED
Tracking Status
firefox-esr52 --- unaffected
firefox59 --- unaffected
firefox60 blocking fixed
firefox61 --- fixed

People

(Reporter: lidel, Assigned: jlorenzo)

References

Details

(Whiteboard: [releaseduty])

Attachments

(2 files, 1 obsolete file)

I've read https://www.mozilla.org/en-US/firefox/59.0/releasenotes/ but I am unable to download Firefox 59. Website keeps offering me latest beta (60b3) instead.
Tested on Linux and Mac, under Firefox and Chrome.

# How to replicate

1. open https://www.mozilla.org/en-US/firefox/59.0/releasenotes/ (or https://www.mozilla.org/en-US/firefox/)
2. click on "Download now" 
3. firefox-60.0b3.tar.bz2 (beta) will be returned instead of Stable (59)

# Expected behaviour

firefox-59.tar.bz2 (latest stable) should be returned instead.


# additional diagnostics

Impacted pages:
https://www.mozilla.org/en-US/firefox/
https://www.mozilla.org/en-US/firefox/all/
https://www.mozilla.org/en-US/firefox/59.0/releasenotes/

"Download now" button on these pages use the same link to download.mozilla.org:

$ curl -sIL 'https://download.mozilla.org/?product=firefox-latest-ssl&os=linux64&lang=en-US' | grep Location                                                                                                                130 ~/local/opt/firefox

Location: https://download-installer.cdn.mozilla.net/pub/firefox/releases/60.0b3/linux-x86_64/en-US/firefox-60.0b3.tar.bz2
I can confirm this
Severity: major → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: Bedrock → Bouncer
Product: www.mozilla.org → Webtools
Version: Production → other
This should now be fixed. Please confirm.
Looks like this is misconfiguration in our release automation - when Beta shipped we updated the release aliases instead of the beta ones. It's being fixed right now.
Component: Bouncer → Release Automation
Priority: -- → P1
Product: Webtools → Release Engineering
QA Contact: catlee
I think this is a problem with https://dxr.mozilla.org/mozilla-central/source/taskcluster/ci/release-bouncer-aliases/kind.yml#48 and/or https://dxr.mozilla.org/mozilla-central/source/taskcluster/taskgraph/transforms/bouncer_aliases.py -- we don't make any distinction between "beta" and "release" when deciding which bouncer product to update. We'll try to get this fixed before 60.0b4 starts.
Assignee: nobody → jlorenzo
Whiteboard: [releaseduty]
Comment on attachment 8958915 [details] [diff] [review]
[build/braindump] Unset release_type when not rc r=aki

Hm, do we want `None` or `null` or `release_type: ` ?
I'm good with whichever one works, maybe they all do :)
Attachment #8958915 - Flags: review?(aki) → review+
Comment on attachment 8958917 [details]
Bug 1445672 - Do not rely on release-type to define alias name

https://reviewboard.mozilla.org/r/227788/#review233548

Thank you!

::: taskcluster/ci/release-bouncer-aliases/kind.yml:53
(Diff revision 1)
> -      bouncer-products: ['apk']
> +      bouncer-products-per-alias:
> +         by-project:
> +            mozilla-beta:
> +               fennec-beta-latest: apk
> +            mozilla-release:
> +               fennec-latest: apk

Same comment about `default`, `maple`, and `birch` as below. If this patch works as-is, these comments aren't blockers.

::: taskcluster/ci/release-bouncer-aliases/kind.yml:66
(Diff revision 1)
> +                  firefox-beta-latest: installer
> +                  firefox-beta-stub: stub-installer
> +              mozilla-release:
> +                  firefox-latest-ssl: installer-ssl
> +                  firefox-latest: installer
> +                  firefox-stub: stub-installer

Do you need a `default` here? It might be nice to specify `birch` and `maple` as well, for easier merges + testing.
Attachment #8958917 - Flags: review?(aki) → review+
null it is. Carrying over r+
Attachment #8958915 - Attachment is obsolete: true
Attachment #8958935 - Flags: review+
Pushed by jlorenzo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b21e78ce143d
Do not rely on release-type to define alias name r=aki
https://hg.mozilla.org/mozilla-central/rev/b21e78ce143d
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.