privacy.resistFingerprinting.block_mozAddonManager stopped working v60.0b3

RESOLVED INVALID

Status

defect
RESOLVED INVALID
a year ago
10 months ago

People

(Reporter: 59762c34, Unassigned)

Tracking

60 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180312152746

Steps to reproduce:


1. Set privacy.resistFingerprinting.block_mozAddonManager to true in addons:config
2. Use an already installed extension or install again to work on addons.mozilla.org. Example uBlock origin
3. uBlock origin cannot block anything


Actual results:

privacy.resistFingerprinting.block_mozAddonManager stopped working v60.03b

Extension can't block anything


Expected results:

Extension should have worked on AMO.
(Reporter)

Updated

a year ago
Summary: privacy.resistFingerprinting.block_mozAddonManager stopped working v60.03b → privacy.resistFingerprinting.block_mozAddonManager stopped working v60.0b3

Comment 1

a year ago
regressionwindow
https://hg.mozilla.org/integration/mozilla-inbound/json-pushes?changeset=39e131181d442409a5df2ed945c02aca2b9baca2&full=1

Since bug 1415644, you also have to modify the value of extensions.webextensions.restrictedDomains to remove the domains you want to affect.

Also see bug 1310082, comment 32.
Status: UNCONFIRMED → RESOLVED
Has Regression Range: --- → yes
Has STR: --- → yes
Last Resolved: a year ago
Component: Untriaged → WebExtensions: Request Handling
OS: Unspecified → All
Product: Firefox → Toolkit
Hardware: Unspecified → All
Resolution: --- → INVALID

Updated

10 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.