#text nodes between TR nodes cause nextSibling and previousSibling not to work as expected

RESOLVED DUPLICATE of bug 26179

Status

()

Core
DOM: Core & HTML
--
minor
RESOLVED DUPLICATE of bug 26179
16 years ago
5 years ago

People

(Reporter: Dennis, Assigned: kinmoz)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc2)
Gecko/20020510
BuildID:    2002051006

because there #text nodes inserted in the dom between each TR node, nextSibling
does not provide the next table row, but a blank #text node (and previousSibling
has similar problems)

Reproducible: Always
Steps to Reproduce:
1. create a table with multiple rows
2. attempt to navigate it with nextSibling/previousSibling


Actual Results:  have to use nextSibling.nextSibling to get to the next TR

Expected Results:  it should go to the next TR with nextSibling

Comment 1

16 years ago
off to kin
Assignee: anthonyd → kin
(Reporter)

Comment 3

16 years ago
sorry, nothing I tried in the search would turn up anything

*** This bug has been marked as a duplicate of 26179 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Component: DOM: Traversal-Range → DOM: Core & HTML
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.