Can't delete a QA contact from edit components

RESOLVED FIXED in Bugzilla 2.16

Status

()

Bugzilla
Administration
P1
normal
RESOLVED FIXED
19 years ago
5 years ago

People

(Reporter: Bryce Nesbitt, Assigned: justdave)

Tracking

(Blocks: 1 bug)

unspecified
Bugzilla 2.16

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
If you try to delete an initialqacontact from the above URL, you get:

Changed initialqacontact for program='Office/Misc' and value='Office'
The name is not a valid username. Please hit the Back button and try again.

It does not perform the delete.

Updated

18 years ago
Status: NEW → ASSIGNED
Priority: P3 → P2

Comment 1

18 years ago
tara@tequilarista.org is the new owner of Bugzilla and Bonsai.  (For details,
see my posting in netscape.public.mozilla.webtools,
news://news.mozilla.org/38F5D90D.F40E8C1A%40geocast.com .)
Assignee: terry → tara
Status: ASSIGNED → NEW

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 2

18 years ago
So, I can't reproduce this behavior myself, and I can't get into your version to 
see what's going on (tried to get it to send me a password but no dice), so 
closing this out.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
Tara, I can duplicate it on mine.  I have 2.11 CVS updated yesterday.  Note that 

he's talking about editcomponents.cgi, not about deleting a QA contact from a 

bug...   I get this:





------ cut here ------

                                                       Bugzilla version 2.11 

 Update component 



                       



Sorry, I can't delete the initial QA contact.



Back to the query page or edit more components.

------ cut here ------



To me, this looks like a feature.  If you have QA Contacts turned on, then you 

should have one.  There's nothing wrong with having the bug owner be his/her own 

QA Contact...

Reopening according to Dave's comments.

All throughout Bugzilla the assumption is made that there does not need to be a
QA contact.  If we were going to make it compulsory, there's a lot more things
that we would need to fix.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Target Milestone: --- → Bugzilla 2.16
See bug #83153.  This is also an issue when adding new components.
Priority: P2 → P5
Priority: P5 → P1

Comment 6

17 years ago
-> New Bugzilla Product
Assignee: tara → justdave
Status: REOPENED → NEW
Component: Bugzilla → Administration
Product: Webtools → Bugzilla
QA Contact: matty
Version: other → unspecified
This should be closed. If you have QA Contacts turned off, you don't need them.
If you have them turned on, it should be compulsory to have one. Making it
otherwise leads to the Mystery User and other horribleness, doesn't it?

Gerv
No.  All of Bugzilla supports empty QA contacts, except this one place that
someone broke.

There's no good reason to require QA contacts on all products.  If some people
don't want QA contact, and some do, surely they might be people on different
products.
Created attachment 58504 [details] [diff] [review]
Allow empty QA contacts on components.

Apparently Terry put this restriction in a while back, but existing components
aren't forced to have QA contacts if they never did.

If we decide we don't want to do this, we need to fix up bugs instead.	The
most important thing is consistency here, I think.

This also deals with bug #83153.

Updated

16 years ago
Blocks: 115177
*** Bug 83153 has been marked as a duplicate of this bug. ***
Comment on attachment 58504 [details] [diff] [review]
Allow empty QA contacts on components.

r= justdave x 2

painless change, works as expected.  I'm a bit worried to note that the
components listing shows "missing" in red letters on the components that don't
have them.  It should probably just say "none" instead.  But I can file a
different bug for that since it doesn't really affect this.
Attachment #58504 - Flags: review+
/cvsroot/mozilla/webtools/bugzilla/editcomponents.cgi,v  <--  editcomponents.cgi
new revision: 1.20; previous revision: 1.19

We should probably file a new bug if there isn't one already to make this a
per-product setting, which we can enforce.
Status: NEW → RESOLVED
Last Resolved: 18 years ago16 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.