can't open most links in the page in a new window or tab

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
17 years ago
8 years ago

People

(Reporter: caliper, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

As above. When the link is left clicked, it opens in the current window.

Reproducible: Always
Steps to Reproduce:
1.Open the above link
2.Right click on most links (if not all) and click open in new window or open in
new tab
3.Nothing happens

Actual Results:  nothing happens

Expected Results:  open in new link or window

Comment 1

17 years ago
Seeing this too, trunk 2002051308, XP.
A similar bug at another page at same site was resolved as WFM in bug 123742
OS: Linux → All

Comment 2

17 years ago
it looks like the problem is that the "Open link in new window" option does not
appear on linked images, only on text links.

Comment 3

17 years ago
Confirming, Linux 2002 6/29 #4.  Only left click works on the links.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
Component: Browser-General → XP Apps: GUI Features
i get this error :
JavaScript error:
chrome://communicator/content/contentAreaUtils.js line 74: focusedWindow._conten
t.location has no properties

middle click (new tab), open in new window or open in new Tab via conect menu
doesn't work.

-> XP APPS
Assignee: Matti → blaker
QA Contact: imajes-qa → paw

Updated

17 years ago
Status: NEW → ASSIGNED
clobbering "assigned" (mistake from blu3)
Status: ASSIGNED → NEW
jst, it seems kinda wrong that setting window.content changes window._content....
There's nothing wrong with a web page setting .content, the problem is that we
actually look at .content (or ._content) in a content window. We should never
ever touch .content (or ._content) in anything other than XUL windows.

Comment 9

17 years ago
Getting the same error at http://bigbrother.iprimus.com.au/

W2K/Moz 1.0 

Comment 10

17 years ago
the bigbrother.iprimus.com.au site is indeed the same problem. from their script:

var content = new Array();
...
// fundraising;
content[0] = tOpen;
content[0] = content[0] + "<tr><td>&nbsp;&nbsp;<a href=\"/news.asp?id=666\"
class=\"dhtml\">Starlight</a></td>" + tTab + "</tr>";
...

Comment 11

16 years ago
is this the same bug 138198 ? can't right click open new tab on links this
site's pop-ups
http://tivo.weaknees.com/index.php
Product: Core → Mozilla Application Suite
Assignee: bross2 → guifeatures
QA Contact: pawyskoczka
Filter "spam" on "guifeatures-nobody-20080610".
Assignee: guifeatures → nobody
QA Contact: guifeatures

Updated

11 years ago
Component: XP Apps: GUI Features → UI Design

Comment 13

8 years ago
WORKSFORME: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.2pre) Gecko/20110420 SeaMonkey/2.1pre
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.