Remove unused grippy binding

RESOLVED FIXED in Firefox 61

Status

()

RESOLVED FIXED
8 months ago
7 months ago

People

(Reporter: bgrins, Assigned: timdream)

Tracking

(Blocks: 1 bug)

unspecified
mozilla61
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox61 fixed)

Details

Attachments

(3 attachments)

(Reporter)

Description

8 months ago
This binding isn't used by Firefox: https://dxr.mozilla.org/mozilla-central/search?q=grippy.

Additionally there's CSS in the various splitter.css files and also some image files that should be removable: https://searchfox.org/mozilla-central/search?q=grip-.*%5C.gif&regexp=true&path=.

This binding can be migrated to comm-central if it remains necessary there.
(Reporter)

Updated

8 months ago
Blocks: 1446163
Assignee: nobody → timdream
Status: NEW → ASSIGNED
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Attachment #8960592 - Flags: review?(enndeakin)
Attachment #8960593 - Flags: review?(adw)
Attachment #8960594 - Flags: review?(dbaron)
The commits completely remove the word "grippy" from m-c.

I don't think there is any grippy in Thunderbird, but there are in Sunbird and Seamonkey. Who should we give heads-up to for the later two applications?

Screenshot: https://screenshots.mattn.ca/compare/?oldProject=try&oldRev=ffda3ab9975f01ea4091f769753f96735c75d62f&newProject=try&newRev=cadb1feb29ee16d012d6401e4fcfdb55de0629c5
There are grippies in the Thunderbird address book at least.
(Reporter)

Comment 6

8 months ago
(In reply to Tim Guan-tin Chien [:timdream] (please needinfo) from comment #4)
> The commits completely remove the word "grippy" from m-c.
> 
> I don't think there is any grippy in Thunderbird, but there are in Sunbird
> and Seamonkey. Who should we give heads-up to for the later two applications?
> 
> Screenshot:
> https://screenshots.mattn.ca/compare/
> ?oldProject=try&oldRev=ffda3ab9975f01ea4091f769753f96735c75d62f&newProject=tr
> y&newRev=cadb1feb29ee16d012d6401e4fcfdb55de0629c5

(In reply to Neil Deakin from comment #5)
> There are grippies in the Thunderbird address book at least.

The grippy binding can be restored in c-c as has been done with xpfe autocomplete and others.

Comment 8

8 months ago
mozreview-review
Comment on attachment 8960593 [details]
Bug 1446157 - Follow-up, Remove unused #placesTreechildren style rules

https://reviewboard.mozilla.org/r/229346/#review235308

Nice!
Attachment #8960593 - Flags: review?(adw) → review+
Depends on: 1447751

Comment 9

8 months ago
mozreview-review
Comment on attachment 8960592 [details]
Bug 1446157 - Remove unused grippy binding

https://reviewboard.mozilla.org/r/229344/#review235768
Attachment #8960592 - Flags: review?(enndeakin) → review+

Comment 10

8 months ago
Pushed by timdream@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/de560a993de1
Remove unused grippy binding r=enndeakin+6102
https://hg.mozilla.org/integration/autoland/rev/be65061c2d72
Follow-up, Remove unused #placesTreechildren style rules r=adw
https://hg.mozilla.org/integration/autoland/rev/2491f8caeffa
Follow-up, Remove unused grippyhidden="true" attribute from Layout Debugger r=dbaron
Backed out for failing browser chrome at browser/base/content/test/static/browser_all_files_referenced.js

Push that contains the failure: https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=bf5816cd4b5e3b7a0b5f45bc69fb03ee3cfb7c1f

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=169671575&repo=autoland

Backout: https://hg.mozilla.org/integration/autoland/rev/e1bd2a0806123389100e53c448c1c45cc44fa47b
Flags: needinfo?(timdream)
Duplicate of this bug: 1348525
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Sorry for overlooked that on Try.
Flags: needinfo?(timdream)

Comment 17

8 months ago
Pushed by timdream@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/0c3cc2c68723
Remove unused grippy binding r=enndeakin+6102
https://hg.mozilla.org/integration/autoland/rev/8a9f69a7ea6c
Follow-up, Remove unused #placesTreechildren style rules r=adw
https://hg.mozilla.org/integration/autoland/rev/cbcc7b902237
Follow-up, Remove unused grippyhidden="true" attribute from Layout Debugger r=dbaron

Comment 18

8 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/0c3cc2c68723
https://hg.mozilla.org/mozilla-central/rev/8a9f69a7ea6c
https://hg.mozilla.org/mozilla-central/rev/cbcc7b902237
Status: ASSIGNED → RESOLVED
Last Resolved: 8 months ago
status-firefox61: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Moving to Core:XUL per https://bugzilla.mozilla.org/show_bug.cgi?id=1455336
Component: XP Toolkit/Widgets: XUL → XUL
You need to log in before you can comment on or make changes to this bug.