Closed Bug 1446171 Opened 2 years ago Closed Last year

Web page element is drawn over browser toolbar / sidebar. And Some element is flickering and jerky

Categories

(Core :: Graphics: WebRender, defect, P1)

x86_64
All
defect

Tracking

()

RESOLVED DUPLICATE of bug 1455839
Tracking Status
firefox-esr52 --- unaffected
firefox59 --- unaffected
firefox60 --- unaffected
firefox61 --- unaffected

People

(Reporter: alice0775, Unassigned)

References

(Blocks 1 open bug, )

Details

Attachments

(2 files)

Reproducible: always

Steps To Reproduce:
0. (Optionally) Enable Menubar and Sidebar
1. Open http://ondras.zarovi.cz/demos/nojs/
2. Click "Click here to start the presentation…"
   --- observe
3. Click Pointing symbol ☞
   --- observe

Actual Results:
Web page element is drawn over browser toolbar / sidebar.
Some element is flickering
Transition is jerky
> Web page element is drawn over browser toolbar / sidebar.

Confirmed in Nightly 61 x64 20180315100042 de_DE @ Debian Testing (KDE, Radeon RX480).
gfx.webrender.all;true + browser.tabs.drawInTitlebar;true
Happens when loading https://ondras.zarovi.cz/demos/nojs/#slide1.
Attached file another testcase
Attached image screenshot
screenshot(after scroll page) of the attachment 8963561 [details]

streetwolf reported see http://forums.mozillazine.org/viewtopic.php?p=14796825
See Also: → 1438007
This seems to be fixed now. I used mozregression to bisect and found it was fixed by bug 1457891. I didn't check the try builds to see exactly which PR fixed it.
Status: NEW → RESOLVED
Closed: Last year
Depends on: 1457891
Resolution: --- → FIXED
bug 1457891:
> WR @ 4b65822a2f7e1fed246a492f9fe193ede2f37d74
mozregression --repo try --launch c02f2c9507c6524a05a04c40b78b8c741e7a5010 --pref gfx.webrender.all:true startup.homepage_welcome_url:'https://ondras.zarovi.cz/demos/nojs/#slide1'
bad, parts are drawn on sidebar.

> WR @ a2dec3b0aea6b719325946a1b855df49ab33a3c9
mozregression --repo try --launch 9dab22f0fa803da8a1267b36bc32f026ab5b78bc --pref gfx.webrender.all:true startup.homepage_welcome_url:'https://ondras.zarovi.cz/demos/nojs/#slide1'
good

Fix range: https://github.com/servo/webrender/compare/4b65822a2f7e1fed246a492f9fe193ede2f37d74...a2dec3b0aea6b719325946a1b855df49ab33a3c9

Most likely servo/webrender#2707 (bug 1455839).
Resolution: FIXED → DUPLICATE
Duplicate of bug: 1455839
You need to log in before you can comment on or make changes to this bug.