Lock icon remains open, does not display as secure site

VERIFIED WORKSFORME

Status

--
major
VERIFIED WORKSFORME
17 years ago
2 years ago

People

(Reporter: nojunkinmybox, Assigned: ssaux)

Tracking

1.0 Branch
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc2) Gecko/20020510
BuildID:    2002051006

Lock icon remains open on secure sites.
Reproduces on http://www.paypal.com

Reproducible: Always
Steps to Reproduce:
1.Go to any secure site.
2.
3.

Actual Results:  Lock icon does not "lock"

Expected Results:  Should lock

I depend on this "lock" for a visual confirmation.

Comment 1

17 years ago
http://www.paypal.com is not the url to a secure site.
Which subpage there do you refer to? Please include steps to reproduce.

Testing with trunk 2002051308, XP,
https://qtestpage.intuit.com/test/encryption.asp triggers lock icon as it loads.

Comment 2

17 years ago
Reporter mailed:

------- Additional Comments From dark@c2i.net  2002-05-14 18:47 -------
http://www.paypal.com is not the url to a secure site.
Which subpage there do you refer to? Please include steps to reproduce.

https:\\www.paypal.com (automatically loads as https with NS 4.79) Loads with
icon locked with IE 6, Opera 5.12.

Testing with trunk 2002051308, XP,
https://qtestpage.intuit.com/test/encryption.asp triggers lock icon as it loads.

Does not lock with Win98 and Mozilla, even after page is loaded.  It worked
somewhat better with RC1 but was not reliable.

Thanks!
Amy 

Comment 3

17 years ago
Reporter: You can write directly in the bug by clicking link near top of bugmail
and using form for "Additional Comments" on web.

paypal has both a secure and insecure page:
https://www.paypal.com is secure and the lock icon triggers
http://www.paypal.com is an ordinary page, that doesn't trigger encryption, so
the lock icon doesn't change there - nor should it.

Still unable to reproduce failure at the other site you menitoned.
Like paypal, they too have an insecure (http://) version of the page.
Are you absolutely sure you've seen the secure lock icon fail to trigger when
you've been to the https:// version of the sites?

Comment 4

17 years ago
Reporter mailed:
..

Hey! Problem (hopefully) solved.
Did a complete uninstall.  Cleaned my registry.  Did a complete new install. I
had 'layered' RC2 over RC1 and I suspect that's what caused the lock icon to fail.

Sorry for the trouble, but it may be worth noting?

Thanks again 'cause I'm happily browsing!!!
Sounds like this is worksforme, but I will forward it to PSM just in case they
see anything they want to look into. If not, please mark the bug resolved.
Assignee: mstoltz → ssaux
Status: UNCONFIRMED → NEW
Component: Security: General → Client Library
Ever confirmed: true
Product: Browser → PSM
QA Contact: bsharma → junruh
Version: other → 2.3

Comment 6

17 years ago
Works for me.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 7

17 years ago
Verified. Reporter, if you are still having problems, you might try a clean 
install - deleting the directory that contains mozilla.exe and its 
subdirectories.
Status: RESOLVED → VERIFIED

Comment 8

17 years ago
*** Bug 146109 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Component: Security: UI → Security: UI
Product: PSM → Core

Updated

10 years ago
Version: psm2.3 → 1.0 Branch
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.