desktop icon in Ubuntu 16 for Firefox 59.0 (32-bit) is extremely large

RESOLVED INVALID

Status

()

RESOLVED INVALID
a year ago
a year ago

People

(Reporter: mailbox, Unassigned)

Tracking

59 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20180313132741

Steps to reproduce:

just installed new version through standard update of Ubuntu today


Actual results:

FF icon on desktop is super-large


Expected results:

it should have standard size like other desktop icons

Comment 1

a year ago
Same problem after update yesterday on 64-bit Ubuntu 16.04

Comment 2

a year ago
Same problem on my 16.04 ( Ubuntu / Unity ) and FF 59.0.1

This « bug » affects many users as described here https://forum.ubuntu-fr.org/viewtopic.php?pid=21890638#p21890638

A workaround seems to set manually the icon as proposed here https://ubuntu-mate.community/t/firefox-v59-has-a-ridiculously-large-static-desktop-icon/16205/5

But the default situation is not « sane ».

Comment 3

a year ago
The « workaround » only applies to the actual icon on desktop.

Any new Firefox launcher will have a bigger size.

coeurnoir@Asgard:~$ ls -l /usr/share/icons/hicolor/128x128/apps | grep firef
lrwxrwxrwx 1 root root    70 mars  16 04:38 firefox.png -> ../../../../../lib/firefox/browser/chrome/icons/default/default128.png
coeurnoir@Asgard:~$
Duplicate of this bug: 1446596
This appears to be a distribution issue and not a Firefox specific issue as it is not the only one affected by this. 

https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/969687
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID

Comment 6

a year ago
1- are you sure it only happens in Ubuntu ?
2- why FF 59 links to a 128 px icon - see #3 ?
3- FF icons were not located in that folder before, that's not a distribution change, is it ?
4- quoted old bug just shows it is some wrong settings in each program and not a distro specific problem.

Comment 7

a year ago
Not resolved / why invalid ?
1. Looks normal in Arch Linux and Ubuntu 14.04, Linux Mint and Antergos use a different icon for their versions of release, OpenSUSE uses the ESR version of Firefox.

2. You should file a different bug if you consider that an issue.

3. I'm not sure about this one, but see above.

4. An official Mozilla binary is not installed the same way as a distribution package is. So if an issue is reproducible with the distro provided package then it's their problem to investigate.

Comment 9

a year ago
Ok !

Thanks for explanations ;-)

I most probably misread / misunderstood some reviews about FF Quantum or Ubuntu, and thought there were no longer so much differences between official Mozilla binary and distribution-packaged ones. My mistake.

Comment 10

a year ago
about 3)

Icon location for FF seems to have changed with v59 ( at least in Ubuntu 16.04 )

usr/lib/firefox/browser/icons no longer exists

and

../../browser/chrome/icons/default seems to be the new one.

…but maybe this is a distribution related.
You need to log in before you can comment on or make changes to this bug.