Closed Bug 1446496 Opened 2 years ago Closed 2 years ago

Revive some expired *_TIME_ACTIVE_SECONDS telemetry probes

Categories

(DevTools :: General, defect, P3)

defect

Tracking

(firefox60 fixed, firefox61 fixed)

RESOLVED FIXED
Firefox 61
Tracking Status
firefox60 --- fixed
firefox61 --- fixed

People

(Reporter: jryans, Assigned: jryans)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

DevTools tracks user session time for each tool via some *_TIME_ACTIVE_SECONDS histograms.

A few of the probes have since expired:

* DEVTOOLS_ABOUTDEBUGGING_TIME_ACTIVE_SECONDS
* DEVTOOLS_RESPONSIVE_TIME_ACTIVE_SECONDS

I am creating a dashboard with this data, so I'd like to revive them.
In addition to reviving the two probes above, I'd like to mark all such DEVTOOLS_*_TIME_ACTIVE_SECONDS probes as opt-out.
Comment on attachment 8959662 [details]
Bug 1446496 - Revive DevTools time active probes. datareview=francois

https://reviewboard.mozilla.org/r/228484/#review234350

Looks fine to me.
Attachment #8959662 - Flags: review?(jdescottes) → review+
Summary: Revive some expired *_TIME_ACTIVE_SECONDS probes → Revive some expired *_TIME_ACTIVE_SECONDS telemetry probes
Comment on attachment 8959656 [details]
Data Collection Review

1) Is there or will there be **documentation** that describes the schema for the ultimate data set available publicly, complete and accurate?

Yes, in Histograms.json.

2) Is there a control mechanism that allows the user to turn the data collection on and off?

Yes, telemetry setting.

3) If the request is for permanent data collection, is there someone who will monitor the data over time?**

Yes, jryans.

4) Using the **[category system of data types](https://wiki.mozilla.org/Firefox/Data_Collection)** on the Mozilla wiki, what collection type of data do the requested measurements fall under?  **

Category 2.

5) Is the data collection request for default-on or default-off?

Default-on, all channels.

6) Does the instrumentation include the addition of **any *new* identifiers** (whether anonymous or otherwise; e.g., username, random IDs, etc.  See the appendix for more details)?

No.

7) Is the data collection covered by the existing Firefox privacy notice?

Yes.

8) Does there need to be a check-in in the future to determine whether to renew the data?

No, permanent.
Attachment #8959656 - Flags: review?(francois) → review+
Pushed by jryans@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/5c282081cd97
Revive DevTools time active probes. datareview=francois r=jdescottes
https://hg.mozilla.org/mozilla-central/rev/5c282081cd97
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
Ryan, any concerns about uplifting these to beta? They are key metrics for exploring detailed panel usage and filtering out accidental usage and having them in 60 release would speed this up.
Flags: needinfo?(jryans)
(In reply to :Harald Kirschner :digitarald from comment #11)
> Ryan, any concerns about uplifting these to beta? They are key metrics for
> exploring detailed panel usage and filtering out accidental usage and having
> them in 60 release would speed this up.

Seems fine to do, especially since there aren't any code changes here.  I'll make a request.
Flags: needinfo?(jryans)
Comment on attachment 8959662 [details]
Bug 1446496 - Revive DevTools time active probes. datareview=francois

Approval Request Comment
[Feature/Bug causing the regression]: No regression.
[User impact if declined]: We would like to revive these telemetry probes more rapidly by uplifting these probe changes to Beta.
[Is this code covered by automated tests?]: Not a code change.
[Has the fix been verified in Nightly?]: Yes.
[Needs manual test from QE? If yes, steps to reproduce]: No.
[List of other uplifts needed for the feature/fix]: None.
[Is the change risky?]: No.
[Why is the change risky/not risky?]: Only changes telemetry definitions.
[String changes made/needed]: None.
Attachment #8959662 - Flags: approval-mozilla-beta?
Comment on attachment 8959662 [details]
Bug 1446496 - Revive DevTools time active probes. datareview=francois

devtools probes unexpired and made opt-out, approved for 60.0b14
Attachment #8959662 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.