Closed Bug 1446638 Opened 4 years ago Closed 11 months ago

History hidden when releasing back button

Categories

(Firefox for Android Graveyard :: General, defect, P3)

Firefox 60
All
Android
defect

Tracking

(fennec?, firefox64 wontfix, firefox65 affected, firefox66 affected)

RESOLVED INVALID
Tracking Status
fennec ? ---
firefox64 --- wontfix
firefox65 --- affected
firefox66 --- affected

People

(Reporter: cousteaulecommandant, Unassigned)

References

Details

Long-pressing the back button on Android displays a history menu, but as soon as I release it, the menu closes.
So far the only workaround I have found is to swipe from the button to the menu and that somehow keeps the menu open.

Android 7.1.1
Phone: bq Aquaris U
Firefox 60.0b4
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → Android
Hardware: Unspecified → All
See Also: → 1328538, 1408645
To summarise - Android N apparently messed up back button handling, so we added a workaround in bug 1304688.
However as it turns out from this and the other bug reports, this workaround sadly isn't applicable to all devices - maybe later versions of Android N (API level 25? Or just 7.1.1 or 7.1.2?) fixed/further changed the back button handling again, or some vendors did their own changes (and Samsung apparently messes up things further by wanting to emulate the former menu button on a long press of the back button).
tracking-fennec: --- → ?
Could someone try to fix this in time for the next Firefox release? This is more annoying than it seems.

Some info:

OS: Lineage OS 14.1 (Android 7.1.2)
Firefox: 62.0.3

From my tests I found that the issue depends on the "Touch & hold delay" in the Accessibility settings: if the delay is set to "Short" the issue exists as reported above. If the delay is set to "Medium" or "Long" the history menu doesn't show at all.

The last working version (on the same Android version and device) is Firefox 49.0.2, so Firefox 50.0 introduces the regression. This proves that Android Nougat is not the culprit (at least not 7.1.2) and that the workaround for Bug 1304688 does more harm than good. In my opinion, a workaround for a bugged or customized Android version should not cause a bug in all the others. Please fix this.
Duplicate of this bug: 1500077
Workaround #2 is to hold the back button with one finger and then press the history entry with another finger, but that involves using both hands.
Is this still affecting 66/65?
Flags: needinfo?(sorina.florean)
Priority: -- → P3
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #5)
> Is this still affecting 66/65?

Yes, I was able to reproduce this issue on the latest Nightly (66.0a1) and the latest Beta. Device: Nokia 6(Android 7.1.1).
Flags: needinfo?(sorina.florean)
Out of curiosity (see bug 1328538 comment 14), can anybody of those with an affected device try Chrome [1], go to chrome://flags and enable #long-press-back-for-history [2] and then see whether their tab history menu works without problems?


[1] Version 70 or newer.
[2] If that option isn't available, your Chrome is either older than Chrome 70, or presumably this feature has already been enabled by default and the flag already removed again.
Duplicate of this bug: 1520653

For me, it works fine in Chrome with the flag set, but not in Firefox. Bq Aquaris X with Android 8.1.0.

Confirmed not working in Firefox 65 with Asus ZenFone 3, running Android 8.0.0. tested working fine in Chrome with no flag changes required.

Also on the ZenFone there is no obvious workaround, two fingers does not work, or dragging from bottom of screen, the history is always dismissed...

(In reply to Jan Henning [:JanH] (away in June) from comment #7)

Out of curiosity (see bug 1328538 comment 14), can anybody of those with an
affected device try Chrome [1], go to chrome://flags and enable
#long-press-back-for-history [2] and then see whether their tab history menu
works without problems?

Worked like a charm :( (Chrome 74, flag seems to be enabled by default). Still having trouble in Firefox beta (68.0b5)

This was fixed... Until the new big Firefox update of July 2020... Now the recent popup doesn't appear at all on my Oppo A5 2020 the button vibration occurs but otherwise no effect on the program... It clearly can work as it was fine up until the new hotness (which is great in most other ways)

Unfortunately it indeed wasn't reimplemented in time for the big update, but it's already working again in Nightly Nightly, so you can check it out there. If you have any feedback, please open an issue at https://github.com/mozilla-mobile/fenix/issues.

Eventually, this will then appear in the release version again, too.

(In reply to Jan Henning [:JanH] from comment #14)

Unfortunately it indeed wasn't reimplemented in time for the big update, but it's already working again in Nightly Nightly, so you can check it out there. If you have any feedback, please open an issue at https://github.com/mozilla-mobile/fenix/issues.

Eventually, this will then appear in the release version again, too.

It seems to have been implemented now in Beta. And, to my surprise, it fixed the issue on my device! I guess this could be closed as fixed. Thanks!

This is likely not relevant anymore as we rewrote the front end.

Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → INVALID
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.