Intermittent testing/marionette/harness/marionette_harness/tests/unit/test_screenshot.py TestScreenCaptureContent.test_scroll_default | application crashed [@ dalvik-jit-code-cache (deleted) + 0x653c]

RESOLVED DUPLICATE of bug 1442054

Status

defect
P5
critical
RESOLVED DUPLICATE of bug 1442054
a year ago
a year ago

People

(Reporter: intermittent-bug-filer, Unassigned)

Tracking

({crash, intermittent-failure})

Version 3
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

a year ago
treeherder
Filed by: apavel [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=168722309&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/NvKm_4w3TkucGzequIwF3Q/runs/0/artifacts/public/logs/live_backing.log

[task 2018-03-17T16:07:15.280Z] 16:07:15     INFO -  TEST-START | testing/marionette/harness/marionette_harness/tests/unit/test_screenshot.py TestScreenCaptureContent.test_scroll_default
[task 2018-03-17T16:07:29.721Z] 16:07:29     INFO -  mozcrash Copy/paste: /usr/local/bin/linux64-minidump_stackwalk /tmp/tmp0vIfSl/4c149de4-0bde-800f-7e42-9a46b1713e23.dmp /builds/worker/workspace/build/symbols
[task 2018-03-17T16:07:40.384Z] 16:07:40     INFO -  mozcrash Saved minidump as /builds/worker/workspace/build/blobber_upload_dir/4c149de4-0bde-800f-7e42-9a46b1713e23.dmp
[task 2018-03-17T16:07:40.384Z] 16:07:40     INFO -  mozcrash Saved app info as /builds/worker/workspace/build/blobber_upload_dir/4c149de4-0bde-800f-7e42-9a46b1713e23.extra
[task 2018-03-17T16:07:40.391Z] 16:07:40  WARNING -  PROCESS-CRASH | testing/marionette/harness/marionette_harness/tests/unit/test_screenshot.py TestScreenCaptureContent.test_scroll_default | application crashed [@ dalvik-jit-code-cache (deleted) + 0x653c]
[task 2018-03-17T16:07:40.392Z] 16:07:40     INFO -  Crash dump filename: /tmp/tmp0vIfSl/4c149de4-0bde-800f-7e42-9a46b1713e23.dmp
[task 2018-03-17T16:07:40.392Z] 16:07:40     INFO -  Operating system: Android
[task 2018-03-17T16:07:40.392Z] 16:07:40     INFO -                    0.0.0 Linux 2.6.29-gea477bb #1 Wed Sep 26 11:04:45 PDT 2012 armv7l
[task 2018-03-17T16:07:40.393Z] 16:07:40     INFO -  CPU: arm
[task 2018-03-17T16:07:40.393Z] 16:07:40     INFO -       ARMv7 ARM Cortex-A8 features: swp,half,thumb,fastmult,vfpv2,edsp,neon,vfpv3
[task 2018-03-17T16:07:40.398Z] 16:07:40     INFO -       1 CPU
[task 2018-03-17T16:07:40.398Z] 16:07:40     INFO -  GPU: UNKNOWN
[task 2018-03-17T16:07:40.398Z] 16:07:40     INFO -  Crash reason:  SIGSEGV
[task 2018-03-17T16:07:40.399Z] 16:07:40     INFO -  Crash address: 0x29aff0
[task 2018-03-17T16:07:40.399Z] 16:07:40     INFO -  Process uptime: not available
[task 2018-03-17T16:07:40.399Z] 16:07:40     INFO -  Thread 0 (crashed)
[task 2018-03-17T16:07:40.399Z] 16:07:40     INFO -   0  dalvik-jit-code-cache (deleted) + 0x653c
[task 2018-03-17T16:07:40.399Z] 16:07:40     INFO -       r0 = 0x0029aff0    r1 = 0x00000000    r2 = 0x0029af5a    r3 = 0x00000000
[task 2018-03-17T16:07:40.399Z] 16:07:40     INFO -       r4 = 0xffffffff    r5 = 0x4c466c94    r6 = 0x2a00d090    r7 = 0x56006290
[task 2018-03-17T16:07:40.399Z] 16:07:40     INFO -       r8 = 0x00000000    r9 = 0x414ba630   r10 = 0x4c466c80   r12 = 0x00000001
[task 2018-03-17T16:07:40.400Z] 16:07:40     INFO -       fp = 0x4bb36970    sp = 0xbea9c758    lr = 0x00000000    pc = 0x5600653c
[task 2018-03-17T16:07:40.400Z] 16:07:40     INFO -      Found by: given as instruction pointer in context
[task 2018-03-17T16:07:40.400Z] 16:07:40     INFO -   1  libdvm.so + 0x2de9a
[task 2018-03-17T16:07:40.400Z] 16:07:40     INFO -       sp = 0xbea9c764    pc = 0x4086be9c
[task 2018-03-17T16:07:40.400Z] 16:07:40     INFO -      Found by: stack scanning
[task 2018-03-17T16:07:40.400Z] 16:07:40     INFO -   2  dalvik-LinearAlloc (deleted) + 0xa79b6
[task 2018-03-17T16:07:40.400Z] 16:07:40     INFO -       sp = 0xbea9c778    pc = 0x4c50e9b8
[task 2018-03-17T16:07:40.400Z] 16:07:40     INFO -      Found by: stack scanning
[task 2018-03-17T16:07:40.400Z] 16:07:40     INFO -   3  dalvik-heap (deleted) + 0x289742
[task 2018-03-17T16:07:40.401Z] 16:07:40     INFO -       sp = 0xbea9c77c    pc = 0x4173e744
[task 2018-03-17T16:07:40.401Z] 16:07:40     INFO -      Found by: stack scanning
[task 2018-03-17T16:07:40.401Z] 16:07:40     INFO -   4  libdvm.so + 0x2b582
[task 2018-03-17T16:07:40.401Z] 16:07:40     INFO -       sp = 0xbea9c780    pc = 0x40869584
[task 2018-03-17T16:07:40.401Z] 16:07:40     INFO -      Found by: stack scanning
[task 2018-03-17T16:07:40.401Z] 16:07:40     INFO -   5  dalvik-heap (deleted) + 0x18e066
[task 2018-03-17T16:07:40.401Z] 16:07:40     INFO -       sp = 0xbea9c78c    pc = 0x41643068
[task 2018-03-17T16:07:40.401Z] 16:07:40     INFO -      Found by: stack scanning
[task 2018-03-17T16:07:40.401Z] 16:07:40     INFO -   6  framework.odex + 0x50c326
[task 2018-03-17T16:07:40.401Z] 16:07:40     INFO -       sp = 0xbea9c790    pc = 0x4dfde328
[task 2018-03-17T16:07:40.402Z] 16:07:40     INFO -      Found by: stack scanning
[task 2018-03-17T16:07:40.402Z] 16:07:40     INFO -   7  dalvik-LinearAlloc (deleted) + 0xc2a6
[task 2018-03-17T16:07:40.402Z] 16:07:40     INFO -       sp = 0xbea9c798    pc = 0x4c4732a8
[task 2018-03-17T16:07:40.402Z] 16:07:40     INFO -      Found by: stack scanning
[task 2018-03-17T16:07:40.402Z] 16:07:40     INFO -   8  core.odex + 0x364ffe
[task 2018-03-17T16:07:40.402Z] 16:07:40     INFO -       sp = 0xbea9c79c    pc = 0x4d7cd000
[task 2018-03-17T16:07:40.402Z] 16:07:40     INFO -      Found by: stack scanning
[task 2018-03-17T16:07:40.402Z] 16:07:40     INFO -   9  dalvik-heap (deleted) + 0x2896ae
[task 2018-03-17T16:07:40.402Z] 16:07:40     INFO -       sp = 0xbea9c7a0    pc = 0x4173e6b0
[task 2018-03-17T16:07:40.402Z] 16:07:40     INFO -      Found by: stack scanning
[task 2018-03-17T16:07:40.402Z] 16:07:40     INFO -  10  dalvik-LinearAlloc (deleted) + 0xa79b6
[task 2018-03-17T16:07:40.402Z] 16:07:40     INFO -       sp = 0xbea9c7f8    pc = 0x4c50e9b8
[task 2018-03-17T16:07:40.402Z] 16:07:40     INFO -      Found by: stack scanning
[task 2018-03-17T16:07:40.402Z] 16:07:40     INFO -  11  libdvm.so + 0xa9c86
[task 2018-03-17T16:07:40.402Z] 16:07:40     INFO -       sp = 0xbea9c7fc    pc = 0x408e7c88
[task 2018-03-17T16:07:40.402Z] 16:07:40     INFO -      Found by: stack scanning
[task 2018-03-17T16:07:40.403Z] 16:07:40     INFO -  12  dalvik-heap (deleted) + 0x2a6
[task 2018-03-17T16:07:40.403Z] 16:07:40     INFO -       sp = 0xbea9c804    pc = 0x414b52a8
[task 2018-03-17T16:07:40.403Z] 16:07:40     INFO -      Found by: stack scanning
[task 2018-03-17T16:07:40.403Z] 16:07:40     INFO -  13  dalvik-heap (deleted) + 0x28966a
[task 2018-03-17T16:07:40.403Z] 16:07:40     INFO -       sp = 0xbea9c808    pc = 0x4173e66c
[task 2018-03-17T16:07:40.403Z] 16:07:40     INFO -      Found by: stack scanning
[task 2018-03-17T16:07:40.403Z] 16:07:40     INFO -  14  libdvm.so + 0x5ff7d
[task 2018-03-17T16:07:40.404Z] 16:07:40     INFO -       sp = 0xbea9c810    pc = 0x4089df7f
[task 2018-03-17T16:07:40.404Z] 16:07:40     INFO -      Found by: stack scanning
[task 2018-03-17T16:07:40.405Z] 16:07:40     INFO -  15  dalvik-heap (deleted) + 0x281006
[task 2018-03-17T16:07:40.405Z] 16:07:40     INFO -       sp = 0xbea9c818    pc = 0x41736008
[task 2018-03-17T16:07:40.405Z] 16:07:40     INFO -      Found by: stack scanning
[task 2018-03-17T16:07:40.406Z] 16:07:40     INFO -  16  dalvik-heap (deleted) + 0x28972e
[task 2018-03-17T16:07:40.406Z] 16:07:40     INFO -       sp = 0xbea9c824    pc = 0x4173e730
[task 2018-03-17T16:07:40.407Z] 16:07:40     INFO -      Found by: stack scanning
[task 2018-03-17T16:07:40.407Z] 16:07:40     INFO -  17  dalvik-heap (deleted) + 0x281006
[task 2018-03-17T16:07:40.407Z] 16:07:40     INFO -       sp = 0xbea9c828    pc = 0x41736008
[task 2018-03-17T16:07:40.407Z] 16:07:40     INFO -      Found by: stack scanning
[task 2018-03-17T16:07:40.408Z] 16:07:40     INFO -  18  libdvm.so + 0xa9c86
[task 2018-03-17T16:07:40.408Z] 16:07:40     INFO -       sp = 0xbea9c82c    pc = 0x408e7c88
[task 2018-03-17T16:07:40.408Z] 16:07:40     INFO -      Found by: stack scanning
[task 2018-03-17T16:07:40.408Z] 16:07:40     INFO -  19  libdvm.so + 0x713a7
[task 2018-03-17T16:07:40.408Z] 16:07:40     INFO -       sp = 0xbea9c830    pc = 0x408af3a9
[task 2018-03-17T16:07:40.408Z] 16:07:40     INFO -      Found by: stack scanning
[task 2018-03-17T16:07:40.409Z] 16:07:40     INFO -  20  dalvik-heap (deleted) + 0x28972e
[task 2018-03-17T16:07:40.409Z] 16:07:40     INFO -       sp = 0xbea9c83c    pc = 0x4173e730
[task 2018-03-17T16:07:40.409Z] 16:07:40     INFO -      Found by: stack scanning
[task 2018-03-17T16:07:40.410Z] 16:07:40     INFO -  21  libdvm.so + 0x7227d
[task 2018-03-17T16:07:40.410Z] 16:07:40     INFO -       sp = 0xbea9c840    pc = 0x408b027f
[task 2018-03-17T16:07:40.410Z] 16:07:40     INFO -      Found by: stack scanning
[task 2018-03-17T16:07:40.410Z] 16:07:40     INFO -  22  libdvm.so + 0xa9c86
[task 2018-03-17T16:07:40.411Z] 16:07:40     INFO -       sp = 0xbea9c844    pc = 0x408e7c88
[task 2018-03-17T16:07:40.411Z] 16:07:40     INFO -      Found by: stack scanning
[task 2018-03-17T16:07:40.411Z] 16:07:40     INFO -  23  libdvm.so + 0xa9c86
[task 2018-03-17T16:07:40.412Z] 16:07:40     INFO -       sp = 0xbea9c848    pc = 0x408e7c88
[task 2018-03-17T16:07:40.412Z] 16:07:40     INFO -      Found by: stack scanning
[task 2018-03-17T16:07:40.412Z] 16:07:40     INFO -  24  dalvik-heap (deleted) + 0x28972e
[task 2018-03-17T16:07:40.413Z] 16:07:40     INFO -       sp = 0xbea9c84c    pc = 0x4173e730
[task 2018-03-17T16:07:40.413Z] 16:07:40     INFO -      Found by: stack scanning
[task 2018-03-17T16:07:40.413Z] 16:07:40     INFO -  25  libdvm.so + 0xae19e
[task 2018-03-17T16:07:40.413Z] 16:07:40     INFO -       sp = 0xbea9c850    pc = 0x408ec1a0
[task 2018-03-17T16:07:40.413Z] 16:07:40     INFO -      Found by: stack scanning
[task 2018-03-17T16:07:40.413Z] 16:07:40     INFO -  26  libdvm.so + 0x29dee
[task 2018-03-17T16:07:40.414Z] 16:07:40     INFO -       sp = 0xbea9c858    pc = 0x40867df0
[task 2018-03-17T16:07:40.414Z] 16:07:40     INFO -      Found by: stack scanning
[task 2018-03-17T16:07:40.414Z] 16:07:40     INFO -  27  dalvik-heap (deleted) + 0x5c626
[task 2018-03-17T16:07:40.414Z] 16:07:40     INFO -       sp = 0xbea9c868    pc = 0x41511628
[task 2018-03-17T16:07:40.415Z] 16:07:40     INFO -      Found by: stack scanning
[task 2018-03-17T16:07:40.415Z] 16:07:40     INFO -  28  dalvik-LinearAlloc (deleted) + 0xa79b6
[task 2018-03-17T16:07:40.415Z] 16:07:40     INFO -       sp = 0xbea9c86c    pc = 0x4c50e9b8
[task 2018-03-17T16:07:40.416Z] 16:07:40     INFO -      Found by: stack scanning
[task 2018-03-17T16:07:40.416Z] 16:07:40     INFO -  29  dalvik-heap (deleted) + 0x28972e
[task 2018-03-17T16:07:40.416Z] 16:07:40     INFO -       sp = 0xbea9c874    pc = 0x4173e730
[task 2018-03-17T16:07:40.416Z] 16:07:40     INFO -      Found by: stack scanning
[task 2018-03-17T16:07:40.416Z] 16:07:40     INFO -  30  dalvik-heap (deleted) + 0x289656
[task 2018-03-17T16:07:40.417Z] 16:07:40     INFO -       sp = 0xbea9c878    pc = 0x4173e658
[task 2018-03-17T16:07:40.417Z] 16:07:40     INFO -      Found by: stack scanning
Duping those bugs against bug 1442054 feels like an endless story.

Sebastian, when can SV finally read that etherpad document and star it correctly? Sorry, but I still don't see an improvement yet.
Flags: needinfo?(aryx.bugmail)
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1442054
There are over 100 issues in that etherpad. To get this fixed, the signature of that crash would need to be stable or Treeherder be able to do dynamic matching. Even if it were to support regex matches, that might be insufficient here due to the different test output and the limit for the Bugzilla summary (255 characters).
Flags: needinfo?(aryx.bugmail)
Comment hidden (Intermittent Failures Robot)
:whimboo :aryx is it safe to say that all marionette crashes with  @ dalvik-jit-code-cache signature are to be classified to bug 1442054 ?
Flags: needinfo?(aryx.bugmail)
:whimbo just so you know, before we make new bugs, we retrigger them, search in bugzilla and etherpad and if we don't find anything, we file a new bug. I did not search for the crash signature, i searched for the file in bugzilla. We are working on improving our classification skills and we will do better in the future.
I would highly recommend that at least for all those crashes happening in a test which scrolls the content, which seem to have a strong correlation here.
Flags: needinfo?(aryx.bugmail)
You need to log in before you can comment on or make changes to this bug.