table / text layout problems with certain page (IE vs Mozilla)

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
17 years ago
16 years ago

People

(Reporter: sspitzer, Assigned: attinasi)

Tracking

({testcase})

Trunk
Future
x86
Windows 2000
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

table / text layout problems with certain page (IE vs Mozilla)

let me give you a screen shot, and I'll attach the html in question.
Created attachment 83669 [details]
here the html to reproduce the problem
Created attachment 83670 [details]
screen shot, IE vs mozilla

Comment 3

17 years ago
I believe this is just differences in strategies in dealing with badly formed
content, and there may not be much to bother doing here.

The HTML in that page is like this:

<BASEFONT size="2">
<FONT face="sans-serif">
<TABLE align="center" border width="50%">
  <p>Fifty-year-old Alistair Beckham was...
</TABLE>

Note that there are no TR or TD in the table. IE seems to eject the content from
the table and applys the BASEFONT and FONT the the inner content. Mozilla seems
to eject the content from the table, and _not_ apply the BASEFONT/FONT.
Tomayto-tomahto.

Comment 4

17 years ago
Created attachment 83672 [details]
simple testcase.

Comment 5

17 years ago
-> parser.
Assignee: attinasi → harishd
Component: Layout → Parser
QA Contact: petersen → moied

Updated

17 years ago
Keywords: testcase

Comment 6

17 years ago
Chris: Why do you think this is a parser problem ( however, there is dataloss,
missing P, that will get fixed with bug 138577 )? According to the content model
BASEFONT should have applied. This is definitely a layout problem.

--> Layout.
Assignee: harishd → attinasi
Component: Parser → Layout
QA Contact: moied → petersen

Updated

17 years ago
Priority: -- → P3

Updated

17 years ago
Target Milestone: --- → Future
I don't think that Seth's initial report was about basefont.... that said, I'm
not seeing the problem his screen shot shows on the HTML he attached.

Basefont is covered by bug 3875.

Marking worksforme, but please reopen if the problem is still reproducible (and
if so, explain clearly what the problem is?  ;) )
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.