Closed Bug 1446764 Opened 2 years ago Closed 2 years ago

Port bug 1439834 to TB: Make #TabsToolbar transparent when styled #titlebar (-moz-window-titlebar) should be shown

Categories

(Thunderbird :: Theme, defect)

All
Linux
defect
Not set

Tracking

(thunderbird60 fixed, thunderbird61 fixed)

RESOLVED FIXED
Thunderbird 61.0
Tracking Status
thunderbird60 --- fixed
thunderbird61 --- fixed

People

(Reporter: Paenglab, Assigned: Paenglab)

Details

Attachments

(1 file)

Bug 1439834 added the -moz-appearance: none; to the menubar and tabbar when drawInTitlebar. We should follow to be consistent with FX. On some themes the background doesn't look the same as the tittlebar's background (especially with Ubuntu Ambiance).
Ace, I know you have some trouble with drawInTitlebar (actually I have too, see bug 1446151) but you are the only Linux reviewer. Please, check if you see a regression.

Because of bug 1446151 you need first to resize the window to make it draw in titlebar.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8959957 - Flags: review?(acelists)
Comment on attachment 8959957 [details] [diff] [review]
Linux-toolbar.patch

Review of attachment 8959957 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, I got the 3 buttons to show on my system and I didn't find any bad effects with the patch.
Attachment #8959957 - Flags: review?(acelists) → review+
Thanks.
Keywords: checkin-needed
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/7c56cb8702d8
Port bug 1439834 to TB: Make #TabsToolbar transparent when styled #titlebar (-moz-window-titlebar) should be shown. r=aceman
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 61.0
Comment on attachment 8959957 [details] [diff] [review]
Linux-toolbar.patch

Bug 1439834 was uplifted to beta. Can we uplift this one too?
Attachment #8959957 - Flags: approval-comm-beta?
Attachment #8959957 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.