Can't copy a msg to newly created sub folder without restarting browser

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Jeesun Cho, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

1.0 Branch
mozilla1.4beta
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt3])

(Reporter)

Description

16 years ago
Can't copy a msg to newly created sub folder without restarting browser
Build: 0512 PR1 

Doesn't matter whether it's a pop or imap account
Steps:
1. Create a new folder
2. Create a sub folder under the folder created in step 1
3. Choose any existing message
4. Go to Message|Copy and select the folder in step 1
5. The sub folder is not found

When you create a sub folder under existing folder, this problem doesn't occur.
Only if you create a folder and a new sub folder below it, you'll see this problem

Note: Move message works OK.

Updated

16 years ago
QA Contact: olgam → sheelar

Comment 1

16 years ago
Confirming this bug on 05-15-PR1 build on all platforms.

The first time I created a subfolder I was able to move message.  But the second 
time I tried to create a new folder and a subfolder is when I saw that I was not 
able to copy message and it would not come up in the menu.  

I also noticed that when you create the subfolder and not click on that 
subfolder before you copy or move a message to that subfolder will also 
reproduce this problem. 

Nominating this bug for RTM.  
Keywords: nsbeta1

Comment 2

16 years ago
Discussed in mail news bug meeting.  Decided to minus this bug.
Keywords: nsbeta1 → nsbeta1-
Target Milestone: --- → mozilla1.2alpha

Updated

16 years ago
Blocks: 157673
(Reporter)

Comment 3

16 years ago
Nominate this bug for Buffy release.
Try this new steps:
1. Create a folder and a subfolder under it (or copy two folders with two levels
from other account)
2. Go to your inbox and select any msg
3. Go to Message|move (or copy) and select your account.
4. Notice that only the first level folder is showing there.
5. Go back to the msg in your inbox.
6. Now, rightclick on you mouse and go to Move To (or Copy To) and select your
account.
7. Notice that even the first level foler is NOT showing there.
Keywords: nsbeta1- → nsbeta1

Updated

16 years ago
QA Contact: sheelar → stephend

Updated

16 years ago
No longer blocks: 157673

Comment 4

16 years ago
Mail triage team: nsbeta1+/adt3
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt3]
Target Milestone: mozilla1.2alpha → mozilla1.4beta
Product: Browser → Seamonkey

Comment 5

13 years ago
confirming on OS/2 Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.7.5) Gecko/20050413

Updated

13 years ago
Assignee: sspitzer → mail

Comment 6

13 years ago
Confirming on Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.9a1) Gecko/20050830
MultiZilla/1.8.1.0h SeaMonkey/1.1a (2005-08-31). Currently, drag'n'drop isn;t
working (again), so I have to right-click and select Move to...I haven't managed
messages this way in some time.

Lewis
To all problem reporters:
(Q1)Is problem when POP3 account or "Local Folders"? Or IMAP account's folder?

If problem when POP3 or "Local Folders", and if problem when copying thru
context menu only(not drag&drop), please read Bug 270871 comment #2 and see
screen shot attached to it.
(Q2) Is this bug same problem as Thunderbird's Bug 270871?

Sounds same problem for me, and if same, it's very very old problem...

Comment 8

13 years ago
(In reply to comment #7)
> To all problem reporters:
> (Q1)Is problem when POP3 account or "Local Folders"? Or IMAP account's folder?
> 
POP3 account; not Local Folders.

> If problem when POP3 or "Local Folders", and if problem when copying thru
> context menu only(not drag&drop), please read Bug 270871 comment #2 and see
> screen shot attached to it.
> (Q2) Is this bug same problem as Thunderbird's Bug 270871?
> 
No. I can confirm that this problem occurs with Copy or Move.

1. Create new folder.
2. Right-click messge in Inbox; select Copy or Move.
3. Scroll across to account folders and select newly created folder as destination.
4. Click to Copy or Move message.

Works as expected. However:

1. Create new folder.
2. Create new subfolder under new folder.
3. Right-click messge in Inbox; select Copy or Move.
4. Scroll across to account folders.
5. While newly created folder is available, it is not expandable, so it is not
possible to copy or move message to newly created subfolder.

Bug 270871 specifically states "This bug does NOT occur in the Copy message
context menu, only in the Move message context menu."

This is inconsistent with the behavior we haev described here.

Lewis
(In reply to comment #8)
> Bug 270871 specifically states "This bug does NOT occur in the Copy message
> context menu, only in the Move message context menu."
> 
> This is inconsistent with the behavior we haev described here.

Lewis, thanks for quick answer.

Did you see my attachment 168273 [details] which is screen shot attached to Bug 270871
comment #2.
This is "Copy thru context menu" case when same secenario as yours.
I think Bug 270871's initial description of "NOT occur in the Copy, Move only"
is invalid or obsolete.   
And I think your "it is not expandable" is same phenomenon of my screen shot.
Is it wrong?

My main concern was whether "drag&drop" is involved or not(especially in your
case), and your answer is "thru menu" only.
I'm now confident that Bug 270871 is DUP of this very old bug, if problem in
mail&news "Core".
I'll set this bug in "Depends on:" of Bug 270871, since this bug is for Mozilla
and Bug 270871 is for Thunderbird.
Lewis, thanks again.
First report on this problem seems to be Bug 67982, which was reported on
2001-02-07.

Comment 11

13 years ago
(In reply to comment #9)
> (In reply to comment #8)
> > Bug 270871 specifically states "This bug does NOT occur in the Copy message
> > context menu, only in the Move message context menu."
> > 
> > This is inconsistent with the behavior we have described here.
> 
> Lewis, thanks for quick answer.
> 
No problem, Wada. ;-)

> Did you see my attachment 168273 [details] [edit] which is screen shot attached to Bug
270871
> comment #2.
> This is "Copy thru context menu" case when same secenario as yours.
> I think Bug 270871's initial description of "NOT occur in the Copy, Move only"
> is invalid or obsolete.   
> And I think your "it is not expandable" is same phenomenon of my screen shot.
> Is it wrong?
> 
Admittedly, I did not read through Bug 270871 as thoroughly as I should have. I
did indeed review your screenshot, and this is, in fact, the behavior I am seeing.

> My main concern was whether "drag&drop" is involved or not(especially in your
> case), and your answer is "thru menu" only.
>
Unfortunately, due to another situation (not sure whether it has been documented
in Bugzilla), I am not currently able to perform any d'n'd operations with this
build (I get an illegal pointer), so I cannot confirm at this point. However, as
the folder is visible in the folder pane, I would guess that dragging to it to
drop a new message for filing would be possible (it was with the previous build
I was using).

> I'm now confident that Bug 270871 is DUP of this very old bug, if problem in
> mail&news "Core".
> I'll set this bug in "Depends on:" of Bug 270871, since this bug is for Mozilla
> and Bug 270871 is for Thunderbird.
> Lewis, thanks again.
No problem. I'll try a couple more builds (read: stable and otherwise) to see if
this has some consistency to it.

Lewis

Comment 12

13 years ago
I rolled back to Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.8b2) Gecko/20050626
MultiZilla/1.8.1.0h, which is capable of drag'n'drop. In fact, I even tested
with springloaded folders (and I never even knew they existed before!).
Drag'n'drop definitely works as expected (and in fact, after moving a message
via d'n'd, the subfolder is then available from the Move menu).

I was able to create a couple nested folders by right-clicking on the mail
account itself and creating first the parent and then the child folder (IOW, I
did not select the parent folder after creating it, so it was never "read"). The
folder subtree showed open after the creation of the nested group; I closed
them, then did a d'n'd move. Hovering over the parent folder, the rest of the
subtree opened as expected, and I was able to drop into the lowest level without
a problem.

I created a new set of nested folders in similar fashion, and after I closed
them, attempted to move a message from the context menu (I did also try to leave
the subtree open and move the message via the context menu). The subfolders were
not visible on the Move menu, but they were visible on the Copy menu.

With regard to your comment #10, I believe you are right, Wada, and this does
indeed appear to be the same issue as reported way back then. Perhaps we should
mark this as a dup?

Lewis
(In reply to comment #12)
>The subfolders were not visible on the Move menu, but they were visible on the
Copy menu.

Sounds Bug 270871's initial description of is correct(sorry for hasty conclusion)
"Both Move & Copy" or "Move only" seems to depend on test procedure.

> (IOW, I did not select the parent folder after creating it, so it was never
> "read")

I also think "folder is opened or not"(newly created folder is clicked or not,
mail copy/move is done or not) has relation to this issue.

I'm experiencing problems of Bug 65303 Comment #45 and Bug 65303 Comment #46,
which are problems after Bug 65303 fixed.
Both seem to be a result of "folder is not opened after rename"(".msf" is not
refreshed after rename).
(Sorry but I haven't opened bug for these problems yet.)

And I experienced mail count of "?" when folder creation many times in the past
with old Mozilla, which was alwayes cleared(changed to blank) by clicking the
newly created folder.
I think ".msf" is still not refreshed when folder creation, although count of
"?" display problem is already resolved. 

So I think "folder is opened or not after creation/move/rename"(.msf is
refreshed or not) has relation to this bug's issue.
Depends on: 67982

Comment 14

12 years ago
WFM - do you agree?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061119 SeaMonkey/1.5a
QA Contact: stephend
Version: Trunk → 1.0 Branch

Comment 15

10 years ago
still WFM 
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b4pre) Gecko/2008020803 SeaMonkey/2.0a1pre
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(In reply to comment #14)
> WFM - do you agree?
(In reply to comment #15)
> still WFM
>(and changed to WORKSFORME)

To Wayne Mery:

Does your "change to WORKSFORME" mean "Bug 67982 & Bug 270871 are also already WORKSFORME"?
(Please see Bug 270871 Comment #13 & Bug 270871 Comment #14 in the past).

Or WORKSFORME for "Can't copy without retsart" part of this bug?
(Even if no folder in context menu, move/copy by drag&drop is possible.)

Or WORKSFORME when problem re-creation procedure of Comment #0?

Comment 17

10 years ago
Hi Wada. Perhaps I didn't do a sufficient test - so if this bug still exists please reopen.  My WFM test was using comment 0, _local_ folder. 

But suggest someone should change the summary if comment 0 isn't a sufficient description of this bug (eg. if it's pop). Or have whiteboard point to the best description. 

I just did one further test using v2 on pop account - created subfolder z, then a under z, and from "message > copy" a doesn't appear under z.  And from context menu under copy, neither z nor a appear. 

Sorry, I can't speak to the other bugs and I don't plan to test them.

Comment 18

10 years ago
correction - my test of comment 17 are _thunderbird_, not SM.  Message on error console (pretty sure there's a bug filed for that)
Error: [Exception... "'JavaScript component does not have a method named: "itemMoveCopyCompleted"' when calling method: [nsIMsgFolderListener::itemMoveCopyCompleted]"  nsresult: "0x80570030 (NS_ERROR_XPC_JSOBJECT_HAS_NO_FUNCTION_NAMED)"  location: "<unknown>"  data: no]

seems to me all these folder bugs are back-end.
You need to log in before you can comment on or make changes to this bug.