When scrolling in mail list window using arrow keys, can have up to 20 of same message listed momentarily

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
minor
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Alexander Kohr, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
Occurs whenever you highlight a message and scroll up or down using the arrow
keys on the keyboard. It lists the same thing about 20 times and then redraws
the mislabled messages either on it's own or when you stop scrolling. This is bd
for people who scan their messages as you scroll by using the keyboard as i do.
 It can be made to look even worse if you have it set to display messages in the
bottom of the window.

 It does not occur if you use the scrollbar.

I have a 500Mhz agp graphics G4 runing os X 10.1.4 with 768Mb of ram

Comment 1

16 years ago
Alexander, please provide the Build ID.
Summary: When scrolling in mail list windo using arrow keys can have up to 20 of same message listed molmentaraly. → When scrolling in mail list window using arrow keys, can have up to 20 of same message listed momentarily
(Reporter)

Comment 2

16 years ago
build 2002042303

Comment 3

16 years ago
Alexander, please attach a screenshot of this problem also.

And yes, try this one also using a new Mozilla user profile.
(Reporter)

Comment 4

16 years ago
Created attachment 84795 [details]
Desktop picture of artifacted redraw.
(Reporter)

Comment 5

16 years ago
Created attachment 84796 [details]
Another picture of the problem that looks cleaner but is still drawn wrong.
(Reporter)

Comment 6

16 years ago
Sorry i have been buisy with work.
I did a couple of things.
I updated to build 2002052303 (this mornings build)
Icreated a new profile.
Set up my email.
The problem still occurs. However it does not seem to be as extreme as with the
other build and profile.
I guess I should mention that my in box contains about 4000 messages and i am
using Imap as the protocal for connecting to the server.

I have enclosed two different screen shots of build 2002052303 with the problem
as the one shows the message multiple times and the other shows an artifacted mess.

Hope this helps.

alex

Comment 7

16 years ago
Well, it still WFM using RC2.

However, if I select the bottommost message and hold the down-arrow key down, I
do see message headers drawn several times, though they do correct themselves
and display is fine when I let the key go.

The closest thing I had to a mailbox as full as your was my Trash, full of
~2,200 messages all marked Read. As there doesn't seem to be a way to mark them
all Unread, why don't you try marking all your messages Read and see if that
still happens. Maybe it'll help narrow it down a bit.
(Reporter)

Comment 8

16 years ago
Created attachment 84902 [details]
Picture with all read.

Well the reason they showed up as unread it that i have two mail drops on
campus for mail server testing and I choose the one i hardly every use.

Anyway marked them all as read and i still have the problem as can be seen.

Comment 9

16 years ago
Alexander, can you still reproduce this problem using a more current build?

Comment 10

15 years ago
No response for four months. Resolving WFM.

Alexander, if you can still reproduce this using a current build, feel free to
reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.