Context menus pop up in wrong location

VERIFIED FIXED in M13

Status

()

Core
XUL
P3
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: Bill Law, Assigned: saari (gone))

Tracking

Trunk
x86
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Right mouse clicking in the content area causes the context menu to appear in
the wrong location.  It appears to be off by the offset of the content area from
the upper-left corner of the overall window.  It is easier to see than to
explain; try it (I just checked in the change to navigator.xul to get the
context menu wired to the content area).

Updated

19 years ago
Assignee: trudelle → saari
Target Milestone: M12

Comment 1

19 years ago
reassigning to saari as p3 for m12

Updated

19 years ago
Blocks: 15157

Updated

19 years ago
QA Contact: beppe → cpratt
OS: Windows NT → All
Verified on MacOS 1999-10-18 build (so OSes changed to `All').

For example, the standard page context menu begins: Back, Forward, Reload, Stop
... With navigation toolbar and personal toolbar visible, a context menu appears
with `Stop' under the mouse pointer. With the toolbars collapsed, the context
menu appears further down -- with `Back' under the mouse pointer.

Correct behaviour would be for the top-left corner of the *first item* in the
context menu to appear about 1~2 pixels south-east of the mouse pointer -- so if
I accidentally click the right mouse button, I don't inadvertently select a
context menu item.
Blocks: 16765

Comment 3

18 years ago
mass-moving all m12 bugs to m13

Updated

18 years ago
QA Contact: cpratt → elig

Comment 4

18 years ago
[Contextual menu bug --- QA Assigning to self.]

Comment 5

18 years ago
http://lxr.mozilla.org/seamonkey/source/xpfe/browser/resources/content/nsContext
Menu.js

is this the file that needs to be fixed?
(Reporter)

Comment 6

18 years ago
No, that's the code that manages the context menu content.  The menu itself is
displayed by underlying XUL stuff (mozilla/layout/xul/base/src/*.cpp) or even
lower-level layout or widget code).
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 7

18 years ago
pavlov and myself are working on menupositioning in nsMenuPopupFrame.cpp right
now.

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 8

18 years ago
this appears fixed in the 12/01/99 build.
I'm marking fixed, anyone object?

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 9

18 years ago
I'm unable to reproduce this using ordinary pages on this morning's Win32/Mac OS
builds.

Since the bug report lacks specific steps to reproduce, and Pavlov thinks its
fixed (and can't reproduce on Linux), I'm rubber-stamping it as Verified-Fixed.

If anyone is still seeing this, please re-open with your comments.
You need to log in before you can comment on or make changes to this bug.