Closed Bug 1447626 Opened 2 years ago Closed 2 years ago

Windows are opening in a windowed mode which isn't maximized anymore

Categories

(Core :: Window Management, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1446264
Tracking Status
firefox59 --- unaffected
firefox60 --- unaffected
firefox61 --- fixed

People

(Reporter: clement.lefevre, Unassigned)

References

Details

(Keywords: nightly-community, regression, Whiteboard: [mozfr-community])

Using most of the time maximized window, When opening a new one or reopening the browser, Firefox used to open them maximized.
Since a couple of Nightly releases, those are now opened in a windowed and not maximized state, whatever previous sizes were.

I believe this is a regression, and I guess size was depending on previous ones before.

Bug noticed on Windows and Linux and I think also OS X.
Whiteboard: [mozfr-community]
I noticed this a couple of days ago as well. On Windows 10.
No matter what I try, such as open new windows, resizing or maximizing them and closing them, restarting Firefox, new windows (normal or private) are still the same size. 

In my case they're very short, a little over twice the height of the navigation bar & tab bar.
I've just updated to 61.0a1 (2018-03-20) and that was the first restart where my window was not full size anymore. It was about half the width of my screen, and 2/3rd of the screen height.
dup of bug 1446264 perhaps?
(In reply to Robert Longson [:longsonr] from comment #3)
> dup of bug 1446264 perhaps?

No idea, this one seems to be specifically about browser restart cases while mine is bout both this and open new windows, so I4m not sure at all. I guess it's better having another's person's mind. And the other bug seems to explicitely mention Windows and Linux.

Besides Windows and Linux, I also reproduced the issue on my mac. The window is even smaller here and instead of being pretty much in the center of the screen, it's on the right side, stuck to the right border of the screen.
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180326100107

I have tested your issue on the latest Nightly build on win 10 x64, Arch Linux, mac OS 10.13.3 and managed to reproduce it. And also tested on the latest Release build, here is not reproducible.

Based on this I've used MozRegression to find the regression range:
 4:30.06 INFO: Last good revision: b61bf51fd0c2f788ce98c96d7f205cc4d5c48424
 4:30.06 INFO: First bad revision: ad5d0d34bddb427b2b89d218d7761c472a64428a
 4:30.06 INFO: Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b61bf51fd0c2f788ce98c96d7f205cc4d5c48424&tochange=ad5d0d34bddb427b2b89d218d7761c472a64428a

It seems that Bug 1439875 has caused this.

@emilio could you please take a look at this?
Blocks: 1439875
Flags: needinfo?(emilio)
OS: Unspecified → All
Hardware: Unspecified → All
This is the same issue as bug 1446264, both happen due to fail to apply sizemode from persisted attribute.

Actually when I was debugging bug 1446264, most of time I use window opening rather than restart, since that's faster.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(emilio)
Resolution: --- → DUPLICATE
Duplicate of bug: 1446264
You need to log in before you can comment on or make changes to this bug.