bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

speed-forums.nl - stylesheet served with wrong MIME type

VERIFIED FIXED

Status

Tech Evangelism Graveyard
Dutch
--
minor
VERIFIED FIXED
16 years ago
3 years ago

People

(Reporter: R.A. Rothengatter, Assigned: Tristan Nitot)

Tracking

Details

(Whiteboard: [eurocontest][MIME-CSS][havefix][havecontact], URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0rc2)
Gecko/20020510
BuildID:    2002051006

Mozilla don't uses stylesheed assigned in <link> tag, I have no idea why?

Reproducible: Didn't try
Steps to Reproduce:
1.place the <link> tag on other places
2.make use of lower/uppercase
3.renamed the css file (also in the href of the link tag ofcourse)

Actual Results:  Mozilla still don't make use of the css file specified in the
<link> tag

Expected Results:  make use of the css file specified in the <link> tag
The server is serving the stylesheet as "text/plain" MIME type, and we don't
support the "text/plain" stylesheet language.  (The type attribute of the link
element is merely advisory, although we do parse stylesheets in quirks mode when
it's used and the server MIME type is wrong.  See
http://mozilla.org/docs/web-developer/quirks/ for information on quirks and
standard modes.)  However, the main problem is that the server is sending the
stylesheet with the wrong MIME type.
Assignee: dbaron → nitot
Component: Style System → Europe: West
Product: Browser → Tech Evangelism
QA Contact: ian → brantgurganus2001
Version: other → unspecified

Comment 2

16 years ago
I have confirmed this with build 2002051608 on Windows XP Home Edition.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Mozilla don't uses stylesheed assigned in <link> → speed-forums.nl - stylesheet served with wrong MIME type
Whiteboard: [eurocontest][MIME-CSS]
they need to fix the mime type for css, as described in
http://developer.netscape.com/evangelism/docs/technotes/incorrect-mime-types/ .
Whiteboard: [eurocontest][MIME-CSS] → [eurocontest][MIME-CSS][havefix]

Comment 4

16 years ago
Contact : contact@rayflexcom.nl
Whiteboard: [eurocontest][MIME-CSS][havefix] → [eurocontest][MIME-CSS][havefix][havecontact]

Comment 5

16 years ago
I wrote a page in 2000/2001 before i guess quirks mode was implemented.  and
then at one point i thought mozilla's implementation of multiple and alternate
stylesheets changed, the reason i thought my site's style broke.

anyway, over a year later and i just found this bug.  i wasn't aware of
quirks/standard mode.  perhaps there should be some feedback to the user that it
is in standard/quirks mode or complain that a style sheet was dropped.  this is
good for developers, and for web audience members who can't a page in mozilla
and have no way of complaining to web maintainers with a clear description for
why the site doesn't work for mozilla.  i believe this is another part of
pushing for a standards-compliant web (besides using a standards-compliant
browser), that people need to be able to have the tools and information to
complain about sites that don't comply.

Comment 6

16 years ago
Reporter : is this bug still present? I get a log on box, but don't have
authorization to this page.

Is it safe to assume, based on comment 5 that this page will now render
correctly in Mozilla? If this problem is not re-affirmed in a few days I will
mark it as resolved.

If you still have a problem with this site please provide instructions to reproduce.
(Reporter)

Comment 7

16 years ago
I have solved the problem, by making a PHP file for my CSS where I send the
following header

header("Content-type: text/css");

I Still don't get my "normal" css files working. But I found this sollution
suitable in my situation.

Yours cincerely,

R.A. Rothengatter

Comment 8

16 years ago
Fixed as per comment 7.

As to a real fix for your problem [instead of a workaround]...
My server [apache] also uses text/plain per default.

In the page i have a link to my stylesheet defined as
<link rel="stylesheet" href="stylesheets/main.css" type="text/css">

Have you tried that?
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 9

16 years ago
v
Status: RESOLVED → VERIFIED
move...
Component: Europe: West → Dutch
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.