Closed Bug 1447734 Opened 2 years ago Closed 2 years ago

Specify Google Play services library version via Gradle

Categories

(Firefox Build System :: Android Studio and Gradle Integration, enhancement)

enhancement
Not set

Tracking

(firefox61 fixed)

RESOLVED FIXED
mozilla61
Tracking Status
firefox61 --- fixed

People

(Reporter: snorp, Assigned: snorp)

Details

Attachments

(1 file)

As with bug 1447729, we no longer need to do anything special here, just specify the version in gradle normally.
Comment on attachment 8961048 [details]
Bug 1447734 - Specify Google Play Services library version in Gradle

https://reviewboard.mozilla.org/r/229800/#review235578

Green BnoGPS would be nice.

::: build.gradle:55
(Diff revision 1)
>          }
>      }
>  
>      ext.kotlin_version = '1.1.51'
>      ext.support_library_version = '23.4.0'
> +    ext.google_play_services_version = '8.4.0'

Let's guard this with `mozconfig.substs.MOZ_ANDROID_GOOGLE_PLAY_SERVICES` so that we get an error of some sort if we try to use a GPS library when we shouldn't.
Attachment #8961048 - Flags: review?(nalexander) → review+
Pushed by jwillcox@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7e634d3b77f9
Specify Google Play Services library version in Gradle r=nalexander
https://hg.mozilla.org/mozilla-central/rev/7e634d3b77f9
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
Assignee: nobody → snorp
Product: Firefox for Android → Firefox Build System
Target Milestone: Firefox 61 → mozilla61
You need to log in before you can comment on or make changes to this bug.