Closed Bug 1447738 Opened 2 years ago Closed 2 years ago

Firefox freezing when closing tabs from touchscreen

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

59 Branch
Unspecified
Windows 10
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1446904
Tracking Status
firefox59 --- affected
firefox60 --- affected
firefox61 --- affected

People

(Reporter: kaha, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.110 Safari/537.36 Edge/16.16299
Firefox for Android

Steps to reproduce:

Firefox frequently freezes when I close tabs in from the touchscreen (tapping the "x" button), Windows 10.

My Firefox is up-to-date (59.0.1 (64-Bit)) and my only add-on is uBlock Origin.

https://www.reddit.com/r/Surface/comments/8610b0/firefox_freezimg_when_closing_tabs_from/


Actual results:

Once that happens, I cannot change tabs, click on anything or scroll in the current tab which I tried to close.


Expected results:

Tab should close when tapping the "X", however, this can be fixed by min- and maximizing Firefox (tapping the Firefox icon in the taskbar twice; the minimize button in the firefox window is unresponsive), after which the tab is properly closed.
Firefox 59.0.1, running Windows 10 on a Microsoft Surface.
See Also: → 1447241
OS: Unspecified → Windows 10
See Also: → 1441239
See Also: → 1439417
See Also: → 1436879
I reproduced the issue on Nightly 61.0a1 (2018-03-25) and Firefox 59.0.1, Windows 10, Surface Pro 4.

Note: On Nightly 61.0a1, the issue can be reproduced only with the finger, not with the pen.

I am marking this issue as New.
Status: UNCONFIRMED → NEW
Component: Untriaged → Event Handling
Ever confirmed: true
Product: Firefox → Core
dup of bug 1441239 ?
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1446904
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.